Defalt gateway route leaving residue after wireguard connection an no internet


#1

I’ve been doing some testing with tunsafe wireguard service. (only netherlands connection seems to be working for me for now but I have gotten other countries to work. temp issue on their side I’m assumimg) they provide a free 30-day wireguard unlimited and then after limiting you.
when you generate a wireguard.conf file from their site it does not include “ListenPort = xxxxx” they support 0-65000. When I cut and paste the client.conf file info into the gl-web wgclient creation ui it creates a succeful configurtion but with a ListenPort which is left blank.

now My understanding is that if left blank it negotiates its own available port. (i could be wrong here)
which does not end up happening. and the gl-wg web status is yellow.
when disconnecting there is route residue or the wg0 interface is still up

Here’s my temp fix
ssh into router
after status has gone to disconnected state from ssh
type “route” (no quotes from here on in in the text)
if wg0 is still up then
type “ifconfig wg0 down”
(command ifdown seems to work sometimes and not)
type “route”
if eth0 still has a only a remote interface ip adress other than your local net for example 1921.168.8.1 good if it has some 10.x.x.x or some 172.x.x.x then do the following

type “ifconfig eth0 down; ifconfig eth0 up”

please note “ifdown eth0; ifup eth0” does not work here for sure.

my views
when modify tunsafe vpn entry you are now forced to define a listenport. wondering if there is a setting to allow negotion of open port or must be specified required for gl-wg scripts to work. no bigge just asking cause then the wgimport page to just pick a port for if it is required

I also have had this same problem with configurations that have worked but the server is down now so I have to use a differnt conection. perhaps a ping to the EndPoint before connecting wg client in web ui and not even starting the connection before it gets a response. then a popup host not found. and even better a check for server first checkbox so in only does this when trouble shooting or for speed in the yellow partially connect state and leaving the wg inteface still connected and route table incorrect?


#2

It is a bug, it will occur the router no Internet connection. We had fixed it last week, but need time to merge to new testing firmware.