Different Wifi 5Ghz Speed Between GL.Inet and My Other Router

So i had Flint and Mikrotik hapAC2, and of course flint is based on Openwrt and so does my mikrotik have been changed to openwrt.

the problem that i wanna know is why my iPhone 13 Pro Max get different speeds with the same exact wireless 5ghz configuration on both devices ?

i have 200mbps internet speed, while using hapAC2 i got 200 but in flint it’s like limited only 100-120mbps

wireless info on Flint

wireless info on hapAC2

/etc/config/wireless on Flint

/etc/config/wireless on hapAC2

maybe someone could help :grinning:

WIFI rate negotiation is always multi-faceted. In your screenshot, the speed of AX1800 in one direction is only 197M, while the speed in the other direction is 866M, which may be the optimal speed negotiated by the algorithm according to different hardware characteristics. You can actually test the speed, the page display may not be accurate.


yes i’ve tested with speedtest.net as i stated before,

i have 200mbps internet speed, while using hapAC2 i got 200 but in flint it’s like limited only 100-120mbps

that’s too bad i mean Flint have better hardware than my hapAc2, but the wifi speed is being limited by hardware as u said. so it’s a downgrade to me when choosing Flint rather than upgrade

it’s just kinda doesn’t make sense to me

Please provide the firmware version, we need to do some testing.

i’ve tried stable 4.1.0 and snapshot 4.2.0 (Compiled 2023-02-04 9:05:26(UTC+08:00)) both do the same thing

We’ll give you some feedback after we test it.

thanks, hopefully i could get full 80mhz speed on 5ghz

i’ve tried this unofficial user made OpenWRT and i could get full AC and AX full 80mhz on my iphone

@luochongjun any progress being made ?


You could try building a Kernel version: 5.4 for Flint from the wlan-ap-5.4 in infra-build, since the Slate AX is the same, I’ve noticed quite a difference between the two, 5.4 missing some 802.11 feature set but better performance wise for 5GHz.

1 Like

i’m not really good at building this kinda thing, can u help maybe ?

Try the 0.99.8 version of SmoothWAN from here Releases · SmoothWAN/SmoothWAN · GitHub
Set it up like the usual OpenWrt device (ignore the apps guide etc)
That one is using latest kernel. It has a quirk with the 5Ghz adapter needing to be disabled before Scan button works, else the results will be empty.

sure, i’ll be test it
thanks for the reference

just weird about this wifi 5GHz problem

i still got limited on 20mhz, guess i’m gonna just sell flint and looking other openwrt official supported

You shouldn’t use FT options or roaming with the stock wpad-openssl.
Do opkg update && opkg remove wpad-openssl && opkg install wpad-openssl --force-overwrite if you need the extra feature set.

htmode is set as HE80 not VHT80 when using the WebUI, are you using LuCI for wireless configuration?

VHT is Wi-Fi 5 (AC), HE is Wi-Fi 6 (AX)

Use stock firmware again with HE since the 5.4 kernel is still in beta.

The problem is whatever setting i have tried on flint it always being limited to 20mhz,
That’s why i said at the first time that with the same exact configuration either FT being enabled or not, flint always be limited to 20mhz

Only the flint openwrt built by solideus that exact fw gave me full 80mhz.

I’ve been spending like 2 weeks to just flash and reflash all kind flint custom and official glinet, and none gave me full 80mhz on AC or AX

The VHT that i set on my config is to tell gl.inet dev that with exact VHT80 vs VHT80, the different outcome that i got

1 Like