Disable IPv6 on AR300M?

I am running into an issue where I’m trying to connect to my OpenVPN server at home, and my AR300M is defaulting to the IPv6 DNS entry. That fails, since I’m not running IPv6 at home. I’ve searched the forums and all the Advanced Settings on the router to try and just disable IPv6. Nothing seems to work.

I’m running 2.261 currently. I also downgraded to 2.26 to see if it was a recent change, but the behavior is the same. My OpenVPN client on the AR300M tries to connect to the IPv6 address assigned by my home ISP, and it fails. It never fails over to the IPv4 address.

Note I can tether my AR300M to my Google Pixel XL, and it is not offered IPv6, so everything works. But this hotel internet I’m connected to advertises IPv6, and this is causing my problems.

Any help would be greatly appreciated.

What did you try?

This? OpenWrt Forum Archive

I appreciate the reply.

I tried the sysctl/proc approach and rebooting. I hadn’t tried removing the IPv6 modules altogether, so I did that. However, the domain resolver still returned the IPv6 address first from nslookup, and OpenVPN still tries to connect to the IPv6 address:

nslookup <my_domain>

Server: 127.0.0.1

Address 1: 127.0.0.1 localhost

Name: <my_domain>

Address 1: <Global IPv6 AAAA record>

Address 2: <IPv4 A record>

And when I try to start the OpenVPN client:

TCP/UDP: Preserving recently used remote address: [AF_INET6]<Global IPv6 AAAA record>:1194 UDP: Cannot create UDP/UDP6 socket: Address family not supported by protocol (errno=124) Exiting due to fatal error

I’m trying to find if the OpenVPN client cached the address off somewhere, but so far I haven’t been able to locate it.

Can you try to set ipv6 to 0 in /etc/config/network

uci set network.wan.ipv6=0

uci commit network

Hi alzhao,

Thanks again for the response with some assistance.

That was actually one of the first things I tried. Currently:

uci get network.wan.ipv6

0

I still have the same issue. It seems that the resolver for some reason is defaulting to IPv6 when doing address resolution.