Disable IPV6 on Flint2

Hey all,

I have the Flint2 and I am looking to disable IPV6. I have disabled it on the GLI admin panel under Network > IPV6, and in LUCI under Network > Interfaces > wwan6. The issue I face is that I am still getting an IPv6 address assigned on devices, and when viewing sites such as https://test-ipv6.com, I can see that I am getting a 10/10 score, stating IPV6 is enabled.

How can I totally disable it?

Thanks!

How do you connect to the internet? Which ISP?

Via PPPOE, Plusnet (UK)

Hmm if it cannot be done by gl-inet ui (the wan settings, its still relative new for me).

There is also a option for ipv6 in the network tab, if both is off perhaps its not in the firmware or not with the combination of pppoe :slight_smile:

Though in luci this is relative easy to accomplish, you can delete wan6 interface in luci → network → interfaces.

Then you edit wan, click on the advanced tab and uncheck ipv6 delegation and if the ipv6 block prefix was set to 60 to none/disabled, then restart wan :+1:

Also…

If you want ipv6 also removed from lan etcetera best is to edit lan interface, also disable ipv6 delegation, then if you go to the dhcp settings tab you can disable all ipv6 dhcp servers, also it can help if you delete ula prefix in luci → network → interfaces → global settings (tab), especially on older versions of OpenWrt this was indeed a extra step to disable it, but i believe it now also works with the two first steps :wink:

But i believe the gl firmware should handle the lan part :thinking:

1 Like

Thank you! This has mostly worked. It’s stopped stating that I have IPV6 on the online tests, however it’s still assigning out IPV6 addresses on dhcp (see example below). Any idea how I can stop that?

1 Like

Hmm unfortunately i seem to have the same issue.

I got a android based tv but also my phone still seem to generate a ipv6.

But i wonder if that ipv6 is not just a placeholder generated by android, if someone can confirm that many thanks :+1:

On windows i dont seem to have it.

Theres maybe one setting in luci besides removing the ula prefix you can try:

Go to luci → network → interfaces → click tab devices → click on edit for br-lan, there is a option to disable ipv6.

I wish OpenWrt made it easier to disable ipv6 with maybe one option :yum:

Hey, thanks for the info! I tried it, but it didn’t change anything :frowning:

I really think its a address android devices generate.

but I cannot be sure 100%, on my windows system it shows as expected no ipv6.

maybe you have a other router / wifi to test if it also shows there a ipv6 as client when it should be off? :slight_smile:

oh… wait a second…

I think its this here :slight_smile:

what Moeler says about link-local addresses reminds me of 169 ips from Windows.

LuCI → Network → Interfaces. Edit WWAN6, WAN6, LAN. Disable Bring up on boot, Request IPv6-address within General Settings. Disable all IPv6 related under the Advanced Settings.

If you’re comfortable editing the network conf directly (see attached HOW-TO):

root@slateax:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix '[redacted]::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth1'
        list ports 'eth2'
        option ipv6 '0'

config device
        option name 'eth1'
        option macaddr '[redacted]'
        option ipv6 '0'

config device
        option name 'eth2'
        option macaddr '[redacted]'
        option ipv6 '0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.8.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option isolate '0'

config device
        option name 'eth0'
        option macaddr '[redacted]'
        option ipv6 '0'

config interface 'wan'
        option device 'eth0'
        option proto 'dhcp'
        option force_link '0'
        option ipv6 '0'
        option metric '10'
        option peerdns '0'

config interface 'wan6'
        option proto 'dhcpv6'
        option disabled '1'
        option device '@wan'
        option reqprefix 'auto'
        option reqaddress 'none'
        option auto '0'
        option peerdns '0'

config switch
        option name 'switch0'
        option reset '0'
        option enable_vlan '0'

config interface 'tethering6'
        option proto 'dhcpv6'
        option disabled '1'
        option device '@tethering'

config interface 'wwan6'
        option proto 'dhcpv6'
        option disabled '1'
        option device '@wwan'
        option reqprefix 'auto'
        option reqaddress 'none'
        option auto '0'

config interface 'guest'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.9.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option multicast_querier '1'
        option igmp_snooping '0'
        option isolate '0'
        option bridge_empty '1'
        option disabled '1'

config interface 'wwan'
        option proto 'dhcp'

config rule 'policy_bypass_vpn'
        option mark '0x60000/0x60000'
        option lookup '53'
        option priority '53'

config rule 'policy_via_vpn'
        option mark '0x80000/0x80000'
        option lookup '52'
        option priority '52'

config rule 'policy_dns'
        option mark '0x100000/0x100000'
        option lookup '51'
        option priority '51'

config interface 'wgclient'
        option proto 'wgclient'
        option config 'peer_2005'
        option disabled '0'

config interface 'modem_1_1_2_6'
        option proto 'dhcpv6'
        option disabled '1'
        option device '@modem_1_1_2'

config device
        option name 'wgclient'
        option ipv6 '0'

config device
        option name 'wlan0'
        option ipv6 '0'

config device
        option name 'wlan0-1'
        option ipv6 '0'

config device
        option name 'bond0'
        option ipv6 '0'

config device
        option name 'bonding_masters'
        option ipv6 '0'

firmware 4.4.6-release1

Then make a backup; reboot.