Disable MT1300 (Beryl) LED's

SSH in – I use Putty on Win10 (select port 22 – hit enter)

Log in using WebGUI credentials

cd /usr/bin (change directory to where you will create your script, in my case to disable front LED)

vi led_off (edit a new file named led_off)

click a (append at current location)

paste following

#stopglinet control

/etc/init.d/led stop

/etc/init.d/led disable

hit Esc, then :wq Enter (write file and exit vi editor)

chmod +x led_off (make it executable)

cd /etc

vi rc.local (edit rc.local to add a call to your new script at boot)

use arrows to move to the end of the last line of the file

hit a (append at current location)

Hit Enter 2x (move down and leave a blank line

paste /usr/bin/led_off &

hit Esc, then :wq Enter (write file and exit vi editor)

Have you tried firmware version 4.1? It supports turning off LEDs on the UI. It also supports setting scheduled switches for LEDs.

Yes, I have tried Beta 4. The switch does not work consistently. I turn off the LED, save and reboot. LED remains on. My hack works all the time.

Thanks for your feedback. We will fix it in next version.

you should add “mt1300_led off” >> /usr/bin/led_off

In firmware 4, can you disable the LED from the UI->system->dashboard

I mean this UI, not luci.

The original solution worked in v3 firmware, the switch works in 4.1