Disable SSID broadcast GL-MT300N-V2


How do you disable the SSID broadcast on the GL-MT300N-V2

You can do it from the Openwrt Luci interface. I think this is under “Advanced settings” or similar. I don’t have the stock firmware installed at the moment.

Under Network > Wireless > General Settings, edit the network setting and select “Hide ESSID”.

I have looked through the Advanced Setting, but unfortunately there is not the option “hide ESSID” My application requires the SSID to be hidden. Are there other ways disable the broadcast of the SSID or is this very common router feature missing? I’ll have to return the product if broadcast can not be hidden.


Try: Luci>Network>Wireless>Edit>Hide

I wish that were true… no “hide” options available

@stuart44 Have you even tried it? Both @glitch and @billingd told you exactly how to do it:

Network → Wireless

After Edit above, scroll down:

I don’t have that option, unless I need do something else

Strange. Mine is set to “Access Point (WDS)” for mode.
Can you explain how you set up the router from the beginning?
How is it connected, is it using WISP? LAN?

What firmware version?

firmware 2.27, the latest. Its just arrived so I’m just have a look really. Its plugged into my router at the moment

Well if luci doesn’t let you hide the ssid, you will have to get down and dirty.
Follow this guide here:

Thanks, will give that a go. Was hoping for a tick box though…

It would usually be like that. For whatever reason Luci is not letting you do it, might be a firmware bug from Gl-iNet or just some specific way that the lan set itself up, i have no idea.