Disable UBOOT Failsafe Mode on GL-AR150

I’m looking for a way to disable the uboot failsafe mode on the AR150. Compiling with
>Image configuration >Preinit configuration options >Disable failsafe
turns off failsafe mode within the compiled image, but the uboot failsafe still works (booting the router with the reset button held for 5 seconds luanches the uboot web UI).

Assuming I am able to disable the failsafe within the uboot source code, are there instructions (or can someone point me in the right direction) for reflashing the uboot on this device?


you can replace the uboot using this one: GitHub - domino-team/uboot-domino

you need to type gl to enter uboot console, if this is what you want to do.

Or if you want to disable uboot console completely, you can just set the delay time to zero in uboot env

Thanks. I’m more concerned with preventing the firmware from being reflashed than with disabling the console. Currently, when the router is booted with the reset button held down for 5 seconds, the router boots into uboot’s web ui. That’s what I need to turn off. If it can be done through environment variables (maybe set ethact=null?), that would be preferable.

Ideally, I’d like to set the environment variables from userspace, but I haven’t found the correct settings for fw_env.config. I keep getting a Bad CRC warning when I use fw_printenv.