Disabling DHCP service on AX1800

So I am wanting to use my RPi running Pi-Hole and Unbound and a server instance of Pi.Alert to handle my DHCP service and security. I have been trying to disable the DHCP service on my AX1800 but would like to know what the recommended way of doing this is. I’ve read about using Luci to disable DHCP for the LAN interface, changing the authoritative setting, changing the max DHCP leases from unlimited to zero, etc… Would be nice if there was a simple toggle to turn the service on and off but alas…

What do you think? Thanks in advance.

Hmm you want to use the dhcp from the pi-hole and use the flint as a headless switch correct?

I’m not sure if the gl ui has support for switch mode maybe there is, usually with normal routers it starts behaving as a switch when the cable which normally goes in wan gets plugged in a lan port, I believe with the flint you still need some configuration.

Natively from luci I would suggest:

Go to interfaces->lan, change connection type to dhcp client and disable dhcp there is a checkbox called ignore dhcp inside the dhcp settings tab, then I believe you get the same behaviour you would expect on other routers by plugging the wan cable in the lan port, and maybe even better you might also want to delete the lan firewall zone so it doesn’t behave like a firewall, since your pi does that, and you want the global firewall rule for forward set to accept in case it creates a time out.

Edit:
Your router ip will be dynamically allocated on the pi network, so you need to access the web interface via the pi network.

Thanks. I’ll give it a try this weekend.