Display Problem with GL-MT3000 Beryl AX and latest snapshot 4.6.0


i just tried the latest snapshot:

  • Version4.6.0
  • Compile Time2024-04-22 17:20:52 (UTC+00:00)

The Router is working fine, but it displays something wrong. I am connected via wifi, but the status for the repeater is: “Repeater (STA) is disabled.Connect”.

Can you please fix that.

Can you click Connect and select your wifi and connect again?

Seems that the router automatically connect to the saved wifi after upgrade but the settings is very compatible in the new firmware.

Or can you clear browser cache or try a private browser tab to see if this is the issue.

I tried both + plus factory reset. Did not help

So you did factory reset, connect repeater again. It connects but display is still not correct?

I am using the same firmware and repeater right now and it is fine.

Anything that could be the reason? e.g. SSID, channel etc?

Maybe your browser disabled websocket?

How can i check that?

I just checked in the android app and it shows the same problem:

Please do this in ssh.

ubus call repeater status
1 Like

ubus call repeater status
“connected”: “00:07:33”,
“ssid”: “Telekom”,
“ipv4”: {
“gateway”: “”,
“dns”: [
“ip”: “”
“config”: {
“ssid”: “Telekom”,
“auto_portal”: false,
“macaddr”: “”,
“protocol”: “dhcp”,
“disguise”: false,
“remember”: true,
“manual”: false
“state_s”: “connected”,
“signal”: -39,
“state”: 2,
“bare_mode”: false,
“fail_type”: “”,
“portal”: false,
“channel”: 140,
“macaddr”: “92:83:c4:44:aa:34”,
“network”: “wwan”,
“device”: “mt798112”,
“bssid”: “10:B3:D6:BD:7C:AF”,
“running”: true

I get this problem from time to time. Only solution I’ve found is to reboot.

What browser are you using?

Tried a reboot and did not help. I tried firefox, chrome and safari on mac os.

I am back to stable 4.5.16 for the moment.

Do you access the Web via https?

Yes. I am redirect to https.

This is buggy. We will fix it soon.

Argh…When i switch off “Force HTTPS” it works perfectly…