DLNA, using microSD card inserted connection MacOS Finder-Network access

Hi, a newbie here, though using the GL.inet “hotspot”
device for over a year now.

I am having some difficulty accessing the networked open
or DLNA data of music files on the microsd card inserted
from MacOS Monterey. I did not have issues before on a
MacOS nor on Windows with this. I go through the
Network connection to connect to the GL-AXT1800 that
shows up in the network connections. Then it asks for
a username and password credentials, which is to be
expected. I am not sure what the username should be?
Is it admin, is it root? I type the password of the device
and I cannot access the data.

I have no problems with Windows 10 or 11 with this and
no password nor username is required in the network settings.

Why is it I cannot access this on MAC? it should not be this
Kodi software on the MAC can access the network DLNA drive
with ease but the Finder on Mac has difficulty. It makes no
sense as may be I am doing something wrong? I even tried
smb://<ip address of the Slate AX 1800> device and it brings
up the Finder Network link and again the username and password
do not work .

Thank you.

Note 'MAC" means media access control; it is a very important distinction when discussing networking vs. operating systems.

It sounds like its trying to connect via Samba/SMB & not DLNA. There’s no such prompt when using VLC’s DLNA function on Windows 10:

Samba/SMB is independent of DLNA services. SMB would require user permissions to be configured.

Try VLC for OSX:

So what is the default username when it prompts for it?
is it admin , is it root? There is no specific username when
one accesses the hotspot via its IP address.

Again, Kodi can access the shared data on the microsd card
and Windows has no problems accessing it as well.
The only problem is MacOS. I used to be able to do this
on Mac and I am not sure what happened.

VLC also asks for username and password (assuming it is
the password of the device when accessing it via its IP address
in a browser).

Something has changed under MacOS.

You can set credentials at GL GUI → Applications → Network Storage → User Management … but that’s related to SMB.

There shouldn’t be such a prompt if using VLC → Universal Plug’n’Play; the media dirs should just be listed per the above screenshot.

Maybe you’re right & OSX isn’t following the expectations anymore. It wouldn’t be the first or last time Apple dictates what you can do with your own computer.

I can access it via UPNP in VLC without username and password
the way it should work like how it works in Windows.

I just do not know why MacOS has issues accessing the shared
data via Finder–> Network way.


It’s been well over a decade since I’ve lasted touched it but Finder isn’t a media player so I doubt it has native DLNA capabilities. It’s a file explorer/manager, isn’t? It’s probably looking to connect over SMB.

I am sorry, I confused DLNA with SMB.
What I mean is that I used to be able to to access
the shared data on the microsd card inserted into
the hotspot device via Finder-> Network feature
to access all of the files being shared on the microsd
under MacOS.

As I said, I have no issues under Windows (also on the same
Mac under Bootcamp) when I boot into that partition .
Kodi software on the Mac can access
the data shared on the inserted microsd card via UPNP, browse
folders link. VLC can too. But MacOS Finder -Network requests
a username and password. I tried admin and root as usernames
and those do not work. I am sure I am typing the correct password
which is the same as when I access the Slate ATX1800 using
a browser via its IP address. I have success there as I have made
modifications, updates to the device easily even going to the
Applications → Network Storage section to enable DLNA, Samba
and other things to make sure the microsd card data is being
shared properly (and it is via Kodi, Windows, etc.).

I think there is a trick with the MacOS Finder->Network way and
I forgot how I did it. However I believe I had not upgraded
to Monterey at that time… I was using MacOS Mojave when I had
success accessing the shared microsd card in the device.

  • MiniDLNA/DLNA is for media streaming, not uploading/download/editing/saving files like spreadsheets.
  • Samba/SMB is for Network Attached Storage file & print functionality but it requires user credentials for access to the user’s remote (NAS) dirs/folders/printers.

Beyond that I’m not sure what to tell you.

Okay then, I give up using MacOS (Monterey) for now.
One final question:
When under mac it asks for name or username, what is the
default username for the hotspot device having the
Slate GL ATX 1800 one? Maybe if gets the “correct”
username to satisfy MacOS (the credentials to be entered
along with the password of the device), maybe it will work.

Otherwise, later I will get another MacOS computer running Mojave
and see how that one behaves. Maybe it is just that Monterey
does something differently – I recently upgraded to Monterey

Thank you.

It really sounds like you don’t have credentials setup for SMB.

Ah, that was it.

I had to add user name to add credentials into the
hotspot. I added some information in the Quick Setup Share
link. I had not done that despite I had enabled SMB
or Samba. I had to do a little more it seems.

I added admin as username and a password.
I will change the username for security purposes
later. :). -something not “admin” that could be obvious.
The password is something other than the password
used to access the hotspot by its IP address.

Now the MacOS (Monterey) can log into it.

Thank you. Maybe that was the trick I performed last time
and forgot it or slipped my mind. It was just puzzling because
I did not need to do this under Windows’ access to the shared
data in the network connections.

Thank you. It works now.

I’m glad you got it sorted; don’t forget to hit ‘solved’.

Solved: where is that? I see solution check mark?
Is that it?

1 Like

Sorry; I meant ‘Solution’; you got it.

Now that I think of it, I should have known better with this.
I had to do the same with my Asus router sharing the
data connected to its USB port. One has to go in and
create a kind of username and password (different from
the router’s credentials) to share data/storage connected
to the router or any of the connected access points
within the network. Then MacOS, Windows can access
the shared data perhaps with a one-time login using
those credentials (username/password).

Thank you again.

1 Like