DNS Leak

Hi - I recently purchased 2 routers the GL-B1400 and the GL-MT1300. I have the following setup:

[B1400]—[My ISP Router]–[WIreGuard/internet]–[MT1300]

The B1400 (WG Server) is @ home and I use the MT1300 (WG Client) for traveling. I have Wireguard setup and working but I can’t seem to fix the DNS leak issue. I have tried all sorts of configs.

Any help is greatly appreciated.


the GL-B1400 and the GL-MT1300
Custom DNS Server
DNS over TLS ,choose Cloudflare
or Dnscrypt-Proxy Settings ,choose Adguard DNS
test websites:
You could fix the DNS leak issue.

Thanks for the info,. I have tried both options and the DNS still leaks. Also and ideally, I want to avoid any 3rd party solution e.g. Cloudfare,.etc. Thanks again

Can you let me know how to use this website?

I tested using dnsleaktest.com and I don’t have dns leak.

test websites:
test the DNSSEC function is uesed

know DNS servers

I guess you could not change more security config with DNS,so need to check,the gl-inet firmware is not do all of them,need do it by yourself.

also DNS leak test here

I think this is not related to dns leak, right?

Interested myself as I use the MT-1300 /w wireguard tunnel. My DNS leak tests went well.

To rly dig into this issue (and help) one needed way more than a vague description like “doesn’t work”.

  • pls tell
    – where does the DNS leak? B1400 side or MT1300 side?
    – How do you test/notice?
  • pls describe your DNS setup (leaking side) detailed enough that a 3rd party was enabled to setup a test environment

1st step in troubleshooting is to isolate the issue: Does it happen inside or outside the own environment?
RN I do use MORE SETTINGS | Custom DNS Server | Dnscrypt-Proxy Settings for DNS setup. So when testing my DNS leakage and am getting an unknown server in CA

the very 1st I do is to choose another DNS server like cisco and test again.
Et voila!

Quite obviously it’s not my machine(s) who ‘leak’ but the DNS resolvers themself. Only possible change is then to choose another upstream DNS resolver.


P.S. Try a leak test /w Yandex as upstream resolver :scream: :wink:

1 Like

Yandex DNS server could not support DNSSEC,may have dns leak.

Whilst DNS leak prevention and DNSSEC are both (individual!) components of privacy protection I don’t see how DNSSEC had much to do with DNS leaks.
When DNS leaks then DNSSEC usually is already circumvented. So you’re derailing here IMO.

1 Like

DNS leaks,could you give me more informaiton?
Witch country do you live in?
The GL-B1400 and the GL-MT1300 are not like MV1000W,could not install AdBlock for anti-hijacking and protection DNS.
I am update config files with Dnscrypt-proxy and Stubby by myself ,so you may need more privacy configs for DNS.
Hope could help you!

…looks like @lepastis602 abandoned this issue - last post from 14d ago :unamused:

Hope send pictures and test video for deal with