Does 3 lit leds (green green red) means I bricked uboot?

TLDR: Does 3 lit leds (green green red) means I bricked uboot on my GL-AR300M? Is it the soc8 chip and is it safe to use an 1.8v eeprom programmer + clamp to write to it? If it’s an incorrect image, where do I download one appropriate for GL-AR300M-v1.3.1 ?

Long version:

I received my AR300M the other day and was pretty happy to see everything was working. Unfortunately, the firmware upgrade didn’t go so well and the web uboot flashing didn’t work. When I couldn’t upload the ubi over uboot’s http client, I looked it up and found the thread about the mtu bug. I attached a uart-usb serial adapter to the board (it’s an GL-AR300M-v1.3.1 missing the pins so I inserted 3 header pins to the GND\RX\TX) and managed to confirm how the upload is getting stuck at different times using different MTUs with kermit.

Trying out a few different settings I managed to flash the clean image with mtu 512 but the booting now failed to find the kernel :frowning: Next I tried tftp to flash the NAND since I figured the bug must be in the http server code. Unfortunately, it failed over bootcount greater than 3 and “setenv bootcount 0” or “setenv bootlimit 5” also didn’t work…

Looking up things again I ended up trying to flash the newer uboot found at here ( “run lu” and a tftp server on ) but that completely bricked things. Now, nothing shows up in kermit when powering on and I’m there’s 3 lit leds (green green red) which I’m guessing indicated a bad EEPROM flash.

So, seeing how I already have a 1.8v EEPROM programmer and a soc8 clamp laying around, can you confirm the soc8 chip next to the reset and mode-switch is the EEPROM? Since I don’t have a backup of the old uboot image it would also be nice to have one known to work.



I attached the picture and a working uboot. Please try.

Burn the uboot at the beginning of the flash. Don’t touch the data on the end of the flash which is radio information.

Tried to read the chip but when it didn’t work I looked it up and it’s a winbond 25q128fv and the only programmer I have at hand is a 1.8v one (EZP XPro) :confused:

Anyhow, I’ll order a 3v programmer but it’s going to take a while. Once I sort things out on my end I’ll get back to this thread.


p.s. I might try using the serial-usb adapter but I don’t even have resistors for the pickups let alone a lab power supply for vcc and ordering takes about the same time so it’s probably not likely to happen…

Finally received the programmer the other day. But it seems the chip was faulty all along :frowning: I managed to make a few reads but most were noisy before the chip finally gave up and stopped giving anything meaningful. I even double checked the programmer itself with an old BIOS I had stored and it read correctly and consistently.

Anyhow, I only managed to get one good read* but I’ll link it here along with an image of the back panel just in case. Looking at the board, I doubt I can solder these little SMT packages but I guess I could give it a shot… Maybe I’ll try wiring a socket in there for easier swapping instead.


*around a dozen different read attempts with only two identical before the chip became completely unreadable and finally died :confused:

are you able to find a new Nor flash?

Yeah plenty of those on ebay. e.g.

There’s also DIP8 25Q128FV so I’m holding off buying anything until I find an SMT -> DIP8 socket. I’ll look up SMT soldering how-to guides or even videos on the weekend before rushing to buy anything though… Something tells me my 20yr old hand-down soldering iron’s tip is too big… :wink:


Edit: Looks like there’s not enough clearance between the other components so an fitting an ad-hoc adapter won’t be trivial:

10 raisers:
20 sockets:

10 pcbs & pins:
5/10 W25Q128FV:

So, solder the bioses to the dip8 pcbs along with pins permanently “converting” them to DIP8 packages. Then solder the raiser soic8 to dip8 adapter with a dip8 socket. And then solder that to the router’s board… It will work but it’s quite the BOM, package size and labor. I’ll probably give up and just solder the bios to board but I’ll leave the “instructions” here for posterity :slight_smile: