Dual WAN on GL-MT2500 with USB > RJ45 adapter

I am trying to configure the Multi-WAN feature on my MT2500. I have installed the relevant drivers for the TPLink UE306 and as far as I can tell this was successful.

I have it hooked up via ethernet cable to my backup WAN (4G connection on a Huawei B535), and I can see that it’s assigned an IP address on the Huawei. However, when I go to the Multi-WAN page I get an error message. This message has always appeared, even before I configured the RJ45 adapter.

I’ve tried having Multi-WAN set to failover mode and then pulling the plug on the primary connection, but this does not result in the traffic going via the secondary WAN.

A couple of screenshots to illustrate the issue…firstly ifconfig details:

192.168.88.x is the MT2500
192.168.68.x is my primary WAN (an ASUS DSL router)
192.168.8.x is my secondary WAN (the Huawei B535 4G router)

And secondly, this is the error message I see on the Multi-WAN page:

Any ideas how I can get this working?!


1 Like

I’m going to answer my own question for the sake of anyone in the future that has the same problem:

When I looked at the network interfaces in LuCI, I could see that tethering was disabled (despite the USB>RJ45 adapter being recognised by the router and active):

Added a new interface that I manually named “tethering” and selected eth2, which is how the MT2500 had named the USB>RJ45 connection:

And hey presto! It’s alive!

I still get the error message in the GLiNet interface, so presumably that’s unrelated to the dual WAN issue. Would be nice if this was not such a PITA to configure tbh! Having Multi-WAN listed as an option in the standard interface, but with no options to actually get the USB port running was really confusing.

The load balancing is great by the way! A speedtest with multiple connections give just about the sum total of the bandwidth from the two connection.

Anyway, hope this helps someone at some point :slight_smile:


Thanks for a very interesting post and solution. Are you able to kindly elaborate on the details of how you installed the relevant drivers for the UE306 and also how you added a new interface in LUCI as I am a total newbie when it comes to tinkering with the more advanced settings of this router. I would really like to try this as my current load balance implementation using PPPoE for one connection and wireless repeating for the second has been very flaky.

I’m also a newbie with this router so take what I say with a grain of salt, but the way I got the UE306 working was to go to the Plug Ins section and search for and install the drivers for the chipset that is in the UE306 (which is Asix AX88179):

Just installed, restarted the router and connected the UE306 to my 4G router and I was able to see the interface when I SSH’d onto the MT2500.

I think I also had to install MWAN3 LuCI app:

As for getting the dual wan working, that took a bit of YouTubing, which I’d recommend doing (search for ‘openwrt mwan’ or ‘openwrt dual wan’). You add the interface in the LuCI interface > Network > Interfaces.

Hopefully that gives you enough to figure it out - as I was figuring it out as I went I didn’t write down every step unfortunately!

1 Like

That’s very helpful. Thank you. Will definitely give it a good go as soon as I get the USB2RJ45 adapter. Thanks again.

1 Like

Got dual-WAN to work now really well on my Slate AX with this setup in a “load balance” mode and my speeds have increased. Big problem though is that when VPN (wireguard client to a commercial VPN - Windscribe) is active “green indicator on”, then I have no access to the internet whatsoever. I am on the latest beta firmware 4.2.0 beta3. Anyone knows of any solution to getting both load balance and VPN to be working at the same time?

Today I tried, after a firmware update, installing these packages again:


But they no longer exist in the plug-ins list!!! Today’s firmware version is: openwrt-axt1800-4.2.1-0325-1679719699.

Anyone has any ideas what happened here and where have these packages gone to?

My Dual-WAN is down for now.

4.2.1 kmod repo will be updated. Pls wait.

1 Like

Thanks for that. Are you able to please let us know when they are available? Appreciate it.

It will be available soon as it will be released.

1 Like

@coldcuppatea Thank you so much for this. Just what I was looking for and I got it working on my Brume 2 with your step-by-step instructions!