Dual wan

How can i setup a Duel wan on my 1800 one is cable internet and the other is tmobile home internet.

1 Like

So both are using cable, right?

You need to change one LAN port to WAN.

It is a little complicated but should be able to achieve that. The most important is to edit /etc/config/network, remove one port from lan and make one config of wan port.

It is a little complicated and only hobbist can do that.

Can this be achieved with an Ethernet switch and plugging in the router WAN port, cable internet port and T-Mobile home internet port?

EDIT: There would be 2 VLANs on the Ethernet switch for the 2 Internet gateways.

I do not work for and I do not have formal association with GL.iNet

I tested this successully on a GL-AR750S Slate with my TP-Link Easy Smart Switch ($25), using the procedure in the above OpenWrt Wiki URL. 2 VLAN’s on the switch were recognized as 2 WAN interfaces in LuCI and were able to connect to Internet.

The same procedure should likely work on the GL-AX1800 and other routers.

I do not work for and I do not have formal association with GL.iNet

3 Likes

here it is how I did it

1 Like

Sharing how I did it - all within the Luci interface - this has been working without issue for more than a month. You should make a backup of your configuration before making any changes.

  1. Go to Network > Interfaces and select the Devices tab. Click configure on the br-lan device. Remove a LAN port from the br-lan “bridge ports” option by selecting the menu and unchecking a switch port such as “lan1”. This port will become it’s own WAN port. NOTE - ETH2 … is labeled “LAN 1” … the ports are: WAN=ETH0, LAN2=ETH1, LAN2=ETH1. I removed ETH2 for the following steps. Save/Apply these changes to remove the selected LAN port from the br-lan bridge.

  2. While still on the Devices page, scroll down and click the “Add device configuration” then select ETH2.

  3. Go to Network > Interfaces and “Add new interface” Give the interface a name such as “wanb” (lower case, no numbers … it will show up as all CAPS). NOTE - I used ETH2 from above and protocol DCHP Client, (Interface name “wanb” (it will show up on Interface tab as all caps - “WANB”). For device select the LAN port you removed from br-lan earlier. Select whatever protocol is required for this interface DHCP, PPPoE etc. Go to DHCP Server tab - check “Ignore interface”). Assign the new interface to the wan firewall zone

  4. Apply any remaining changes.

  5. Test the new interface - use ping to check/verify each connection.

  6. Set up mwan3 - Interface, Member, Policy, Rules to include the new “wanb” interface - there are many tutorials and guides for this - you will have to configure all the settings. When you set up the ‘tracking addresses’ if you change the order of the addresses from those of the WAN port you will be able to identify this new interface in the GL.iNET page Network>MultiWAN.

This will show up on the GL.inNET Admin page - Network>MultiWAN as “Ethernet” … if you changed the order of tracking hostnames you will be able to identify this new WAN connection.

Best of Luck.

@JimC so I used to do this but used repeater to bring in wanb. I never liked using wifi to bring in the wanb so I just tried your instructions and now have a successful connection via the lan port but… its way slower than when I had wanb coming in just via the repeater function as wanb. Is your speed as expected via hardwire?

sorry I missed your question. my WANB seems fast, my use case is the input to WANB is at tethered AR750 using Easytether. My download speed is usually around 5 to 10 Mbps … not fast, so I may not have a useful comparison for you. I have a crappy Frontier ADSL connected to WANA its 5 Mbps max and reconnects several times a day. I have swapped A and B and didnt notice a difference in speed. I have another phone that tethers by wifi … same carrier and that runs about 10 Mbps too. I do vaguely recall having to go thru all the settings more than once, change then save then change back and save … sort of like some settings were not really saving. Maybe look at DHCP for WANB … mine is set to “ignore”. And go through the firewall settings as I remember toggeling those a few times to get it to work … didn’t include those iterations in the description because I assumed they were “operator error”. Lastly, if you have faster service than me (who doesn’t?) then maybe it is really slower. FWIW, I’m on FW v4.1.0 tried to upgrade once and had problems and after a couple hours went back to v4.1.0