Dynamic DNS not working

I have 2 routers:

I am currently trying to set up 2 routers to have one on the go and one at my house, the one at my house would be GL-SFT1200, and the one for the go is GL-AXT1800. I have followed a video guide on this process (https://youtu.be/LXbDg1v65Qs?si=L4W1gVAo-T-D0Og_) Which I was able to do. However, I am not able to get the Dynamic DNS working for the GL-SFT1200. Although I have set up the NAT configuration on my router correctly. I have set it for GL-SFT1200 which is the wireless connection and GL-SFT1200-abe is the wired connection, and for both, I get the same error.


Instead of the letter-based dynamic IP address

Please refer to this screenshot to understand the setup of the nat

Also consider The NAT setup

This is the result from nslookup while connected to the one that will stay at home GL-SFT1200.


I am currently unable to connect to the wireguard server setup at home due to this error more than likely

Hey :wave:

NAT isn’t the main problem. The main problem is, that the GL router isn’t able to see the public IP - because it’s behind another router. In that case, it does not know about the public IP and can’t update the DDNS.

Only ways to go:

  • Removing the first router in front of the GL one or set it into bridge mode.
  • Using another DDNS service from the first router or some device that offers a service like this

Being behind another router and using DDNS does not work with GL DDNS.

1 Like

I have both a MT2500 Brume 2 and an AR750S Slate at different locations with their WAN port connected to NetGear main routers LAN. The NetGear main routers WAN port is connected to the internet.

In this configuration, both of the GL.iNet devices are getting private 192.168.x.x WAN IP addresses from the NetGear main routers. With DDNS enabled on each, they are registering the main router’s external IP address in gl.ddns, not their private WAN IP address from the NetGear.

From your statement, this shouldn’t be working, but it does.

Hmm, maybe the functionality change on different firmware versions / devices. Do you have GoodCloud enabled?

I was pretty sure that they register the WAN IP and not using some reflector to get the current one. Maybe I am wrong …

On another note, why would the router configuration say
If the GL.iNET is not allowed to be behind another router. The router where I am setting the NAT is my ISP router.

Currently, AT&T does not support bridge mode, although it is a fiber modem router. There should be a configuration that I can use in order to get a public IP for my GL-SFT1200 I just have not figured it out yet and it would be helpful if some assistance is provided

I figured out the solution. I was able to set it up after setting IP passthrough settings on the ATT router. This was able to give me a public IP which was needed for the dynamic DDNS

1 Like