Wireguard setup: is this Port Forwarding that causes issues?

Hi all, I am a newbie to glinet routers, and not that tech savvy either (in fact, not at all). Believe me, I tried to look for and read most of the posts first, tried many times with both routers then rebooted and tried again, but still cannot figure it out so I am posting this question. Please help if you can.

I wanted to set up WireGuard server on a router that stays home and WireGuard client on a travel router to have home IP address to work while using the travel router.

My current equipment:

  • Home in the US: Comcast router -------- Google nest wifi (WAN) -------- (WAN) Beryl AX
  • Remote location will be similar: ISP router ------ TP Link Mesh (WAN) ------ (WAN) Slate AX (LAN) ------- (LAN) laptop

Here is what I have done so far:

  • Beryl AX.
  1. Enabled DDNS, ran DDNS test and saw this message ( “the IP address from DDNS domain resolution is not the same as the WAN IP of the device. You need an Internet Public IP address to use Dynamic DNS”) but I proceeded anyway.
  2. Set up Wireguard server
  3. Set up port forwarding on Google nest to BerylAX through Google Home app
  • Slate AX
  1. Set up Wireguard client
  2. Enabled Wireguard client
    but the message “The client is starting, please wait …” stays like that forever. I tested it on my 5g through my phone but no traffic at all.

What did I do wrong?

  • I tried connect the BerylAX to Comcast router through LAN but there is no internet, the WAN port is taken by the Google Nest.
  • I tried Port Forwarding from Comcast router to Google Nest but it didn’t work either.

Any thoughts? Thank you

Hi :wave:

That is almost what happens here. Since the router cannot see the WAN IP, it can’t register this IP against the DDNS service. Use https://dnschecker.org/ against your DDNS address to see if it resolves to the right IP.

Make sure to read this note here:

This should be the part that has problems.

  1. Check if you have public IP on your comcast router.
  2. Do your comcast router and Google nest both has NAT. If yes then you need to set up port forward on both routers.

Pls post images so that we can help.

Don’t do this. Don’t connect the LAN port of Beryl AX to Comcast.

Thank you, I will look into the post and see how it goes.

Thank you.

  1. How do I know if my Comcast router and Google nest have NAT?
  2. I learned that the LAN of either Comcast or Google nest port should connect to the WAN port of the Beryl AX.

If they wouldn’t have, you would know :wink:

It works after I did 2 times of port forwarding, from Comcast to Google Nest and then Nest to Beryl AX and tested on a different network than my local network.