E750 C6 Mudi stack on booting

Hi everyone!

I got a problem with starting up my router. When I switch it on, “Booting …” progress bar is getting frozen roughly at 90%.
I tried following, but no success:

  • Holding reset for 4 seconds: no success
  • Holding reset for 10 seconds and trying power on, no success
  • Holding reset for 15 seconds with ethernet connected, I was not able to boot into uboot. Ethernet port never showed that there is a cable connected and status was the same (booting progress bar is stack at 90%)

Could you please advice, what can I do to move forward?

Regards, Denis

Seems that the firmware died.

You can try use uboot to debrick.

When you use uboot to debrick, you should do it in the correct way.

  1. Connect cable from Mudi to your pc using the port replicator.
  2. Press down the reset using a pin and power on Mudi
  3. The screen will show counter and after several counting it will display “Please open web” and it is on uboot mode.

You should download latest firmware 3.201.img and upload to the router via uboot. GL.iNet download center

Hi Alzhao

This is exactly what I was trying to do a lot of times. I have 2 questions.

  • Is it really important to use exactly cable from Mudi? I have a lot of usb-c cables (I tried with different ones, including Thunderbolt 4 certified cable). I’m not sure that i’ll be able to find Mudi cable, probably it will be easier to buy new one.
  • The results are always the same: i’m holding reset button with the stick and power on: and basically no difference, system just get stack on 90% of booting. (port replicator is connected to pc via Ethernet and to usb-c port on Mudi on other end).

Regards Denis.

When you hold the reset and power on, Mudi should to your uboot failsafe mode in several seconds not 90%. The screen will display the info.

Can you give a shot video of what you are doing?

I have multiple devices and with one of them I have this exact same issue. I can’t get into the uboot mode; If I hold reset button and turn it on it just starts the normal booting and stops at 90%; I’ve tried this with another device and it works; The first device is probably bricked… what is the solution for this problem? Device is 2 months old.

You can just talk with the customer service of the channel you bought the device.

Hi, I have the same problem. I buy a device on Amazon from Gl-inet, so only you can help. I think…

Pls talk with support or customer service via email.