E750 WAN not reconnecting

When something happens on WAN interface, such as ISP changes IP at least once a day, the /dev/cdc-wdm0 modem doesn’t reconnect, unless e750 is rebooted.
Usually works ok for many hours; sometimes only a few minutes.

If interface restarted in Luci, last line in system log is:

Waiting for SIM initialization

uqmi -d /dev/cdc-wdm0 --get-data-status

says either:



Incompatible state

or just hangs, and on Ctrl-c gives:

Failed to connect to service

I think the problem is this:

but sending
echo -e "at!reset" > /dev/ttyUSB2
as one fix there has in the cron script, doesn’t reconnect. Sending reset with minicom also doens’t .

I see that even OpenWRT QMI experts there can’t figure out this problem or how to fix it already 4 years.

Can I use some other protocol with this EG25-G modem, instead of QMI?

do you just means that the LTE connection just breaks and you need to reconnect manually?

When it breaks, does the router still keep the original IP address? Or just show not connected?

I am a little confused about the “WAN interface” which generally means cable connection in our routers.

Yes, when it happened, LTE connection breaks. I don’t know how to reconnect manually, except to push the interface Restart button or reboot the whole router.

The router kept the original IP, and even sometimes said it was connected to uqmi get-data-status, but wasn’t connected.

On the e750, the main WAN connection I have is the LTE. I don’t use ethernet port.

A few days now has been working without this problem. So, maybe was something temporary on the ISP network.

Can you manually configure the router to use ttyUSB3 interface?

By default it use qmi which has more problemse.

It worked with USB2 for these 4 weeks with minor problems.
Yesterday, it just stopped connecting to ISP and even in minicom.

Can still uplink to other devices through WIFI interface, but not LTE.
The LTE /dev/cdc-wdm0 and all ttyUSB devices disappeared and do not exist anymore in the file system.

How can this happen?

Does a reboot solve the problem?

I tried reboot several times, and also power cycling.
Has not worked yet.
I also updated all the packages that were upgradable with opkg.

Is it possible that just the LTE device failed?
Otherwise, it’s working well.

Yes it is possible that the LTE module or connection fails.

Maybe open the case and check. Or contact customer service.

1 Like

I’m having trouble exchanging it through vendor who sold it, because of their bureaucracy. (Shopee)
Are there some other global LTE modules I can try that will work?

Maybe you can just get a EC25-G module and change? Not sure if this is the problem of the module itself.

1 Like