Enabling OpenVPN client via the mode switch on the GL-AR750S does not work


#1

I just received the GI-AR750S, the OpenVPN client is working in software (ON/OFF no issues) however, when I flip the physical switch on the router to turn ON the VPN client, nothing happens. Flipping the switch to turn the VPN client OFF works every time the client is running. Any ideas?


#2

I am experiencing the same thing as you! I would love to know the solution. I have to re-enable the VPN through the web client every time as the physical switch does not turn the VPN back on.


#3

@kyson-lok pls have a check of this issue.


#4

@Jynx2120 @Matt1

What vpn service are you using?

Here is the problem, the name of the ovpn file may contains double or signal quotas that break the script. Can you pls rename the ovpn file and upload again?

Pls let me know if this fix your problem.


#5

where do you specify which service should be activated?
most people have more than one…


#6

Hi Alzhao,

I am using PIA. If it helps to know, I am using a Mac.

I have done the following:

  • Updated to the latest test build for my GL-AR750s
  • Purged all profiles under the OpenVPN Client
  • Ensured button settings was set to “No Function” (default) with the physical button turned to the right (off)
  • Redownloaded the latest OpenVPN configurations on PIA’s website (Recommended default)
  • Uploaded the OpenVPN configurations and installed on device
  • Connected to VPN with no issues, then turned the VPN off.
  • Applied the OpenVPN Client Toggle option (on/off)
  • Monitored the Admin Panel as I turned on and off the physical button. Issue still persists. Device has no issues with turning the VPN off, but it will not turn back on.

#7

The switch is also broken on the newest ar750 firmware. Using 3.03.0926 firmware and the switch i can turn the vpn off but not back on.


#8

I’m using PIA as well. I’ll check into the ovpn file.


#9

No double or signal quotas in the name of file, nor in any of the files I’m using. I still renamed the .zip file and re-uploaded and still no change.

Also, found this in the forum… kyson-lok, posted


#10

@Matt1 @Jynx2120 t is a bug in ovpn file with whitespace. Could you ssh into the router and modify a bit?

Pls search “vpn_cfg” on /usr/bin/switchaction, change the line if [ -z $vpn_status ] && [ -n $vpn_cfg ]; then to if [ -z $vpn_status ] && [ -n “$vpn_cfg” ]; then

The script missing double quotas for variable.


#11

Thanks for the instruction kyson-lok however, this didn’t work the problem still persists.


#12

Do you add double quotas manually? Pls don’t copy it directly, seems it has been changed on Markdwon.


#13

No I copied it from your post and pasted it.

This is the line I changed in the file… added “”

if [ -z $vpn_status ] && [ -n “$vpn_cfg” ]; then


#14

Change it to this:

if [ -z “$vpn_status” ] && [ -n “$vpn_cfg” ]; then

Make sure you start the vpn in the gli interface, then reboot. All should be working then


#15

This worked and now all is good! Thank you Exile1975 and kyson-lok.

Note: I updated the firmware too and had to re-implement the code change.


#16

I think i spoke too soon. It seems that the switch won’t turn the vpn back on after turning it off. I also noticed that unless the vpn is running during a router reboot it won’t start with the router


#17

This will fix in next release(3.004). 3.003 still not fix yet.


#18

Odd because I made your suggested change if [ -z “$vpn_status” ] && [ -n “$vpn_cfg” ]; then and now it does work for me. Flipping the switch on now turns the VPN on. If you updated the firmware to 3.003 you will have to go into the switchaction file again and change it.


#19

I updated to the newest testing build 3.004-1010 and the button works! Thank you for the quick fix!