EP06-A modem not working after upgrade on GL-X750

Hello,
I updated the Quectel EP06-A following your guide: Upgrade Quectel Module Software - GL.iNet Router Docs 4
The update was successful and the reply to gl_modem AT AT+QGMR is:
EP06ALAR02A08M4G_01.004.01.004

Unfortunately in Spitz web panel in the internet/cellular section I face a yellow warning "SIM card not registered" when using the exact same setting that were working fine before the update; the SIM is data-only and meant to be used in modem/routers to share connection. Same SIM in a phone is working.

I tried the command
AT+QPRTPARA=3
from Modem FAQ - GL.iNet Router Docs 3
but the problem remains.

AT+CSQ
+CSQ: 99,99

AT+COPS?
+COPS: 0

AT+CPIN?
+CPIN: READY

I tried countless combinations starting from the SIM provider instructions (Iliad Italy) but it seems to be stuck way before the connection/apn.

I also tried to update to latest beta V4 release of the GL-X750 and to roll back to V3, clean config etcetera, same SIM card not registered. It has to be something strictly related to the Quectel modem.

Any clue?

Can the sim card be registered with the device before the module firmware is updated?

Yes, It was registered and working before firmware update.

Do you remember the version number of the module before the update?

Unfortunately not, I just went through the update guide.
Is there a way to recover the initial version?

Is your device X750 or X750-v2?

GL-X750V2C6
So it's v2

http://download.gl-inet.com/download/EP06A-modem-firmware --download url
try this

EP06ALAR02A08M4G_01.008.01.008.zip