EPO6-A not locking to band 66

For some reason my router with the EPO6-A will not lock onto band 66. They seem to have just added a bunch of t-mobile bands to my tower and I would like to test it out. Anyone know why it might be doing this?

EP06-A support band 66. So you tried to lock band using the AT command but it does not work?

LTE-FDD: B2/B4/B5/B7/B12/B13/B25/B26/
B292
/B30/B66;
Up to 2 × CA: B2+B2/B5/B12/B13/B29;
B4+B4/B5/B12/B13/B29; B7+B5/B7/B12/
B26; B25+B5/B12/B25/B26; B30+B5/B12/
B29; B66+B5/B12/B13/B29/B66; WCDMA: B2/
B4/B5

Yep I tried to do it though AT commands and all it says is ERROR. The other bands seem to work fine as far as I can tell.

Pls send screenshot of the modem info page, including modem model and IMEI. I will check with Quectel.

Is there a way to see the original imei? I changed mine to match the original device I had the sim in.

You can give me the modem model (firmware version) first.

If you mean the router firmware version it’s on 3.203 and if you mean the actual 4g module then I have no idea where to find that.

I mean the 4G module.

Ok it’s EP06ALAR02A08M4G

Ok I guess band 66 is working now for some reason. Now my question is shouldn’t it be able to aggregate with itself or some other bands? When I check do the AT command to check carrier aggregation it just says “OK” and the signal indicator doesn’t say 4g+

What is the Cell info? If you do not lock band it should be able to do aggregation.

What is the speed?

I am band locking to band 66 but that doesn’t stop any other bands from aggregating with themselves at least. I also found this guide and tried to use it to aggregate with 66 + other bands and it says “OK” after the AT command but never actually aggregates-LINK. The speeds right now at 11:30pm are 73 down and 20 up.

[
{
“type”: “servingcell”,
“state”: “NOCONN”,
“mode”: “FDD”,
“mcc”: “310”,
“mnc”: “260”,
“cellid”: “1C3D302”,
“pcid”: “376”,
“earfcn”: “66811”,
“band”: “66”,
“ul_bandwidth”: “15M”,
“dl_bandwidth”: “15M”,
“tac”: “A2E5”,
“rsrp”: “-92”,
“rsrq”: “-8”,
“rssi”: “-64”,
“sinr”: “23”,
“srxlev”: “-”,
“rat”: “LTE”
},
{
“type”: “neighbourcell”,
“earfcn”: “66811”,
“cellid|pcid”: “376”,
“rat”: “LTE”
}
]

If you lock band. It will do not aggregation.

The only way is to put it back in automatic band selection. But the modem itself decides if it will do aggregation. The OpenWrt host cannot do anything.

73 is good speed.

Are you sure? If I lock it to band 2 for example it will aggregate but only with itself and not any other bands. I get like 60-70 down with that setup and about 17 up. Also I know 73 is a good speed and I’m definitely not complaining about that I’m just trying to see how fast I can get it.

The modem will not aggregate band 2 and band 2.

It only aggregate two different band.

I know you know more than I do but the data sheet from here says it can-https://www.quectel.com/wp-content/uploads/pdfupload/Quectel_EP06_Series_LTE-A_Specification_V1.7.pdf

And the router itself says it is
Results from AT+ QCAINFO

+QCAINFO: “pcc”,1123,75,“LTE BAND 2”,1,235,-90,-8,-63,23
+QCAINFO: “scc”,852,50,“LTE BAND 2”,1,235,-96,-6,-82,23

Sorry, seems that I was wrong. Definitely not expert in 4G LTE things.

You’re fine. I just know you’ve very active in these forums and want to make sure you have the right information for others and that I myself had the right information. I looked it up and the name for it is intra brand CA if you wanted to look into it.

1 Like

I should probably open up a new topic for this but do you have any idea why I can’t get ipv6 to work? I’be tried changing a bunch of settings around and tried to use every apn I can but when I enable ipv6 in the normal gl.inet menu it just can’t connect at all. I’m using sprint if I didn’t say that in the earlier conversation. Also running the router in qmi mode if that makes a difference.

So now the problem is you enable IPV6 but the modem cannot get IPV6 address? Does the carrier offer you IPV6? Do you need a specific APN?