Error 0x8007003B: An unexpected network error occurred

Have enabled file sharing per the gl.inet documentation. Share works, is visible on the network, can read and write files to the micro SD card in my AR750s. But most writes to the share over 100MB fail with the following:

Error 0x8007003B: An unexpected network error occurred

I was on firmware 3.212, updated to 3.215 - no change
Tried reformatting micro SD card with FAT32 - no change

Micro SD card functioning fine when plugged directly into PC.

Copying small files to the share does not seem to be an issue. Any large files I have are under 200MB.

Has anyone run into this, or have suggestions to try?

3.x firmware samba version is very old. Don’t suggest to copy big files.

Appears I can not even copy an 86MB file to the share. Looks like the files need to be really small, kind of making the share useless. Is there any type of work around? or is there a known max file size limit when copying to the share?

Working now - Tried formatting micro SD card instead with Linux gparted. Tried both ext4 and NTFS, no longer seeing the error with the same files when using either NTFS or ext4 formatting.

1 Like