Error: "Add failed" when adding mullvad VPN (ar750 and AR300m ext)


#1

PROBLEM SOLVED: JUST ENTER THE MULLVAD-ACCOUNTNUMBER MANUALLY


What happened before: …

Trying to add Mullvad as Profile in Wireguard Client … but it does not work …

Here’s what I do:

  1. Go to VPN -Settings, Wireguard Client
  2. Add New Profiles
  3. Go to other, choose Mullvad, enter Accountnumber
  4. ar750 throws error "add failed"

I tried with Firmware versions stable and testing (disabled “keep settings”):
gl-ar750-3.010
gl-ar750-3.013-0129

… same error each time

I bricked my ar750 and had to use uboot to get it going again, tried again with both firmwares, no change, still error on adding mullvad.

please help :wink:

PS: the same happens, when I try to add mullvad profile for wireguard client on router model AR300M-ext, with both standard and testing firmware … same errors


#2

What have Mullvad support said?


#3

maybe related


#4

it’s gl.inet’s implementation-issue … not mullvad’s


#5

kinda related, true, … but different hardware (ar750, not the slate) … and no solution to the issue. because:

i prefer gl.inet’s simple implementation of mullvad as wireguard option … if it only worked …

I rather just click that button, than having to import config-files through ftp, or vim around through ssh or whatelse :wink:


#6

it’s not just slate. its all firmware. I cannot manually add a wiregaurd my ar300m either.

You will have to do it via cli or downgrade to 3.009(?) or wait for the next release


#7

well that’s why I posted the issue …

… sure, what else can i do …

… nope, thanks … i bricked my routers often enough & rather wait till the pretty idea gl.inet already shows off really works … after all there already is a button to easily add new wireguard profiles … it’s just not working … like an escalator that turns out to be just stairs …


#8

Please bear with me, not trying to sound like a douche. Just trying to help.

We have 50 private WG servers worldwide using KVM VPS servers. (FYI Mullvad keeps logs, not good.)
We also have many AR3300m and a few AR750s for work/travel. It’s too hard to continually re-add the WG servers into each version’s update, so we make backup copies of the ‘wireguard’ and ‘shadowsocks’ files before updating to the next version

For us, SFTP is the easiest way., it’s super fast and you can just overwrite the default files in seconds. If you don’t have the saved files, you can also just add your keys and info manually there. Did I say fast?

Just for drill if you don’t have this.
-Create an SFTP server:

SSH into the router, then

opkg update
opkg install openssh-sftp-server

Then, SFTP into the router. Go to /etc/config/.wireguard. Simply overwrite wireguard with your saved wireguard file, or you can manually add each entry into it like this:

config peers ‘wg_peer_a-name’
option name ‘ANY NAME’
option address ‘aaa.bbb.ccc.ddd’
option listen_port ‘yyyyyy’
option private_key ‘your-privatekey=’
option allowed_ips ‘0.0.0.0/0’
option persistent_keepalive ‘25’
option public_key ‘your-publickey=’
option dns ‘1.1.1.1’
option end_point ‘xxx.xxx.xxx.xxx:yyyyyy’

Separate each peer with a line space.

Takes seconds. No head scratching either.

Or, just wait for them to fix the GUI. Should be very soon.


#9

Hmm, maybe I just try doing it the way you described … thanks for writing down howto!

Can you tell me an alternative to Mullvad, if you say they kerp logs (although they write they don‘t in theor website)?


#12

It works for me. Not sure why you can’t add it. Could you please PM me your account number? So that we can debug this issue. If it is possible, you can send it to support@gl-inet.com


#13

Check your account number. Enter it manually not cut and paste.


#14

PROBLEM SOLVED

I just had my “d’oh” moment & feel like Homer Simpson … I really should have thought of that.

Entering the account-number manually solves all problems

God, Mulvad is fast compared to OpenVPN … BUT:
Mullvad does not let me stream TV-Content from country A, when travelling in country B … same as Netflix: just doesn’t work through Mullvad/Wireguard…
but this is a Mullvad issue, no gl.Inet one. Those routers just rock.

Thanks everybody for their help :slight_smile:


#15

Great to hear it works.

We are developing VPN routing policy now, you can configure some URLs, such as Netflix, doesn’t passthrough VPN. It will fix this issue.


#16

Good to hear such a simple solution fixed it, DOH!
The error normally occurs because when you cut and paste the password, sometimes you get a trailing space.