Error Add failed when adding mullvad VPN


#1

The VPN service is active I can use it on my computer, but when I try to add it to the router it says “ERROR: Add Failed.”

Why is this?


#2

More details needed:
Have you uploaded the ovpn file(s) successfully?
If yes, I suspect you got a user/pass error


#3

I’ve done this before. I was using the wireguard client configuration. It worked before, I reset my router and went to do it again. Now it doesn’t work. Checked account number and verified it works


#4

You add using the UI in Wireguard client -> other tab, right?

You have to be in a place that doesn’t block Mullvad api. The router will need to fetch all servers from Mullvad.


#5

Yes. I can add the open VPN profiles with no issue.


#6

Which firmware version are you using? If you just reset the router, it should work like before, unless you had reinstalled gl-wg manually before.


#7

3.003 . I reset my router and it didn’t help…Should I try to reinstall the packages or…?


#8

Could you try to upgrade to the latest testing firmware? You can download it in here.


#9

I upgraded to the latest build and now it works right away. Thank you.