/etc/resolv.conf not using dnsmasq

Looking at /etc/resolv.conf on my AR-750 running the latest firmware, I see that it’s using one of the resolvers it’s upstream (i.e. wifi hotspot) provided and not the local dnsmasq on

Is this expected? Is if fixable/configurable if I want the router to use it’s own dnsmasq instead of the upstream resolver(s)?

You can omit the settings in /etc/resolv.conf

Your client will use the router as resolver. But the router needs to use a valid resolver. By default it will use the one obtained from upstream router. But you can config custom DNS server in the UI.

Yes, understood. But I also want the router to benefit from the settings (i.e. static host entries) on the router.

The dnsmasq on the router should be a valid resolver, even for the router to use itself. At minimum it should be using the resolvers from the upstream router, so should be no different than having the upstream router in /etc/resolv.conf.

I will keep that in mind if/when I ever go back to the GL-iNet firmware. For the time being I have just flashed my custom build of an OpenWRT 19.07.0 firmware.

We have taken a lot of effort to get the dnsmasq working correctly with the UI.

Sorry I cannot go back the all the details of dnsmasq rather than using our UI.