Ethernet Cable Lan to WAN

Normally, when I go to a hotel and if I see a router in my room, I would plug one end of the ethernet cable to the lan port of the router and the other end of the ethernet cable into my Beryl wan port. All works well for the last 6-10 hotels.

However, I am at another hotel today and doing the usual setup does not work. I did plug that lan ethernet cable directly into a SamSung TV and checked its network and I got the following in the picture.

Is there anyway around this? For now, I am using the router in repeater mode with WIFI.


I don’t know how a picture of a failed DHCP request of a TV should explain issues with the Hotel LAN. Repeater mode means ‘take some WLAN and repeat it’. The font have to be a DHCP server in the repeater. In fact it shouldn’t be.
To provide an IP to the Samsung TV, switch to router mode. But this won’t solve your problem in any way.

Today I set up my SlatePlus in router mode over WLAN … Don’t work, I can’t find out why via mobile phone.
So I plugged a LAN cable from LAN of the given router to WAN at the SlatePlus… The Gl-Inet app says ‘IP conflict’ and indeed, the provided LAN works at

I needed to change the routers network to → works perfect.

Thanks for your reply. Maybe I wasn’t explaining clearly. Repeater mode works fine. I have to result in using Repeater mode because I could not get the cable mode in the travel router to work at this hotel.

After plugging the LAN cable from the hotel router into my travel router WAN and it did not work, I wanted to check if it is the LAN cable from the hotel router. Therefore I plugged into the tv if it is also failing like my travel router and it did fail. I am not trying to get the tv to work. I don’t care about the tv. I was trying to diagnosed why the LAN to WAN did not work with my travel router this time.

This brings to your solution. Where would I change the ip address for my travel router? Thanks

In fact, this was really not clear for me. In this case it seems the Hotel WiFi don’t give IP via DHCP. At least not to the Samsung TV.
Does it works with your mobile/laptop? If yes: What IP is assigned to your mobile/laptop?

The hotel router may be set up intentionally to discourage people connecting an Ethernet cable to the router LAN port.

If you assign a static IP address to the router WAN, you may create a conflict should that IP already be in use. Even if you use the DHCP IP address that was assigned to the router WWAN in Repeater mode, that IP would already be leased to the router WWAN MAC address, which may still create a conflict.

To assign a static IP address to the router WAN, go to LuCI → Network → Interfaces → WAN → Edit.

I do not work for and I am not directly associated with GL.iNet

I believe your assessment is right that the hotel setup intentionally to discourage people.

I did what LupuSE asked about plugging the ethernet in directly to the laptop and that too got no service. At least now, I know it is not that my travel router is going bad.

I don’t want to mess around with the settings on my router. I will just stick to the repeater mode since I got that to work, giving around 70 Mbps. I usually prefer cable mode because it gives higher Mbps.

Thanks for your replies to both of you.