Ethernet won't connect to old device

I have a brand new GL-MT6000 Flint 2 and mostly everything is working. But I have an old device with 100Mb/s Ethernet and when I plug it in it fails to connect. The Ethernet port on the router doesn't even seem to see that anything's connected and the device says no Ethernet.

I've tried various firmwares and cables and nothing changes. It's like a physical incompatibility though I've never experienced that with Ethernet before. Is it maybe failing to negotiate because it's so old?

Any ideas for diagnostics or fixes?

Hey :wave:t2:

did you already update to the newest available firmware version for your Flint2?

Yeah I tried that and I've also tried vanilla OpenWRT

Oh, okay. Advanced troubleshooting here, good job!

What does logread and dmesg tell while plugging in?

OK now you're asking. I'll get on it. I also had a brainwave - I have an old switch somewhere and I can try interposing that in the link and see what happens. Cool - thanks for the help so far.

Thu May 23 09:17:57 2024 daemon.notice netifd: Network device 'lan4' link is up
Thu May 23 09:17:57 2024 kernel: [ 8175.079759] mt7530-mdio mdio-bus:1f lan4: Link is Down
Thu May 23 09:17:57 2024 kernel: [ 8175.085084] br-lan: port 4(lan4) entered disabled state
Thu May 23 09:17:57 2024 daemon.notice netifd: Network device 'lan4' link is down

[ 8174.249232] mt7530-mdio mdio-bus:1f lan4: Link is Up - 100Mbps/Full - flow control rx
[ 8174.257098] br-lan: port 4(lan4) entered blocking state
[ 8174.262319] br-lan: port 4(lan4) entered forwarding state
[ 8175.079759] mt7530-mdio mdio-bus:1f lan4: Link is Down
[ 8175.085084] br-lan: port 4(lan4) entered disabled state

I also connected through a cheap switch and it works. So connecting the device directly to the router and the port goes down immediately but via the switch everything works.

If I disable autonegotiation and configure the port to 10M it works.

ethtool -s lan5 speed 10 duplex full autoneg off

Not sure why the negotiation is failing. Also I thought it should support 100. But it's only music so I think 10 is fine.

Is there a chance this is an "MDI-X" issue? Do you have access to an Ethernet crossover plug?

Sorry I don't know what "MDI-X" is and I don't have a crossover cable. The old device is supposed to support crossover but I also thought it was 100 whereas, as I mentioned, I can only get it working at 10 and with the negotiation off. Since I have it working this is not so urgent but I guess it would be cool to find out why it doesn't negotiate correctly.

This is what it says in the really old spec for the device back when 10Mbps was a thing: "100Mbps throughput; Shielded CAT5 RJ-45 connector; Connects to any 100Mbps or 10Mbps network; Auto-detects full duplex and half duplex modes; Automatic receive polarity correction"

And I think the chip is the Davicom DM9161EP

It's a newer standard that automatically detects network crossovers; I think the idea was you don't need crossover cables anymore- but what I was getting at was I think (i.e., don't quote me :slight_smile: ) was that back in the day there were "device" ports and "switch" ports and you couldn't just connect two older Ethernet devices together, so they came up with MDI-X- so maybe your old device thinks the wires are crossed so only 10-BaseT works?

Just a guess on my part, but now I'm curious to see if a crossover can fix that so we'll all know