Expired Key in Surfshark

Hi…i have bought the mango router a few days ago- and i’m about to cut it in pieces…
First days this little device was running as intended- but a few hours ago it stopped working with vpn activated.
Maybe the solution is the expired key into settings! I tried to log out via app - but i cannot log in after that(http status error)…
How can that be fixed?

BTW- i did not get an Email from Surfshark to renew the key…
Thx for your time…

Switch to Surfshark’s WireGuard service instead of OpenVPN & you won’t have to bother with key expiration/renewal. See the Surfshark entry towards the bottom of:

I have never used OpenVpn! I used WireGuard from the beginning…

I’m using Surfshark via WG on a Certa, Flint & Slate AX as I type this. I’ve never seen such an issue though I download the config files directly from Surfshark & uploaded them to the respective devices.

The aforementioned docs show how to setup up Surfshark manually.

I’m sorry for the delay in your use.
First,you can try update the firmware of your mango router,follow this tutorias:

If the problem persists after the firmware upgrade.To solve the problem, I need you to provide Surfshark VPN account information for test. Please leave your email and I will contact you via email next.

I did the update on first use. Everything was fine for the first days- until i was’nt able to get the vpn running. Yesterday i have tried the latest beta and i have uploadet some manual connection files from surfshark- but still not running.
U want me to share my email and also my login for surfshark? Well…i think that is not a good idea^^

Finally i’ve got it to work!
I have logged out from Surfshark in the gli app, went to Surfshark website and created some manual config files.I have added them to several groups to switch servers when needed.
But: I am not able to connect into Surfshark into your app again( http status error)- which was way easier to connect between several locations…
Thx for your answers and sorry for my english, witch is not my native language!

Now the Surfshark of our app is not working normally,We have contacted the supporters of Surfshark to solve this issue. Please be patient for a few days.

Thank you for your time!