ExpressVPN Set Up Not Working GL-MT1300

I added the OPENVPN files, saved. All good. Until I try to connect, I get the following error:

Incoming Control Channel Authentication: Using 512 bit message hash ‘SHA512’ for HMAC authentication

TCP/UDP: Preserving recently used remote address: [AF_INET]

Socket Buffers: R=[163840->327680] S=[163840->327680]

UDP link local: (not bound)

I set it up as a CLIENT VPN not SERVER.

What is this? I am trying to connect via WIFI at a coffee shop but I need the VPN working on the router.
SO, I did some research and found this statement:
Some customer grade routers have problems with IPSec but, more likely, a coffe shop simply allows ports 80 and 443 through the firewall and noting else. The default OpenVPN port is 1194 which may be blocked by a restrictive firewall . I strongly believe that Mullvad will allow you to use port 443 to connect to their servers.
WHen I went home, I tested the router and it works great. BUT, not at the coffee shop which is why I bought this router in the first place.
My question is, if the above is true, how do I got about change the port 1194 to 443 or 80?

Try downloading and connecting with an ExpressVPN configuration file for TCP, instead of UDP.

I do not work for and I am not directly associated with GL.iNet

1 Like

will try that. Thanks!

ExpressVPN said manual configuration is only UDP. Cannot download TCP. Not sure how to go about getting the configuration file.

Try this method:

I do not have ExpressVPN and use NordVPN that provides config files for both TCP and UDP.

In comparing NordVPN config files for TCP and UDP, the only changes are like in the above URL:

  1. Change remote <server IP address> 1194 to remote <server IP address> 443
  2. Change proto udp to proto tcp
  3. Confirm comp-lzo no

Without vpn, the Internet is normal, right?

I tested expressvpn again it just connects. Maybe problem of the Coffee shop network.

The default profile exported from express vpn is udp. Can you try to add the following line to see if it connect as tcp?

proto tcp

Tested and expressvpn file does not change to tcp directly.

Try Step 3 as in the URL of my previous post:

  1. Remove fragment 1300 and comp-lzo no

NordVPN config files do not have fragment, but they have comp-lzo no.

Tested, does not connect with modifications

proto tcp
#fragment 1300
comp-lzo no # pls note it has this alreay

I think I will gave up modifying the default config.

It may be worth to look for another VPN service provider that provides config files for both TCP and UDP.

Best option is get another GL router, plug it in to your current router at home and set it up with wireguard server, then you can just connect to it anywhere without any issues… Wireguard VPN Server would connect you to home and then use Express VPN from the current router. No more config issues