Extender/Repeater with VPN?

I have a Slate AX and I am trying to configure it as a Wi-Fi client with a VPN connection. I am hoping someone might have advice on how to accomplish doing so.

Basically, I want the router to connecting to a public Wi-Fi network and for that Wi-Fi network connection to server as the WAN/Internet connection. I then want to establish an OpenVPN VPN connection over that public Wi-Fi WAN/Internet connection. Finally, I want to connect client devices to the router (either via ethernet cable or even better via a separate Wi-Fi network) and have all traffic from those devices be routed to the Internet across the VPN tunnel.

The only way I see to use the router as a Wi-Fi client and connect to a Wi-Fi network for Internet is to go to settings menu Network / Network Mode tab and select Extender as the network mode. Doing that, I can connect the router to the desired outbound Wi-Fi network. Additionally, the extender network mode allows me to configure a separate Wi-Fi network to which I can connect client devices. However, when I select Extender Mode, the VPN configuration disappears and appears to be disabled. So close. What I am hoping to do is have the Extender Mode functionality plus the VPN functionality. Is that possible?

The drop-in gateway name sounded promising, but looking at the documentation it appears to only work with wired WAN connections. Am I wrong there? Does anything other than Extender mode allow the router to connect to as Wi-Fi Lan connection?

I suppose I could use two separate devices, one as an extender with an ethernet cable connecting to the other which then acts as an inline router with VPN, but I would prefer having only one device to avoid the clutter. Is the Slate AX able to do what I am trying to do? And if not, does anyone have a suggestion for a different device that would be capable of doing so?


You should not use “Extender” mode. It is bridging to the public wifi. You should not bridge to public wifi.

You should set up “Repeater” (WISP) in the Internet section. Just find “connect” button in Repeater section of the Internet page.

That was exactly what I needed. Working great now. Thank so much alzhao.

1 Like