Extremely slow Wi-Fi speeds using repeater on GL-MT3000

So perhaps I should try dowloading the beta software for the Beryl. Can I go back if it does not run at all?

I can get the 3000 Beryl from Amazon tomorrow (via Prime) so maybe I should do that.

I still think the 1300 should work better than it does.

The Beryl MT3000 has the most headroom for bandwidth so I believe it should perform the best as a wifi repeater. You’re always going to get <50% of the speed but the more headroom the better.

I have Comcast ethernet coming into the house via coax.

My Comcast (white) home router connects via ethernet cable to my old iMac at 850 Mbps. (using the Ookla site)

The router connects via wi-fi to my MacAir laptop (in same room) at 550 Mbps.

When using the Beryl (also in same room as router) what should I expect the MacAir laptop to get?


I installed the 4.3.2 beta1 on the Beryl 1300 and now I get 220 - 240 Mbps down with the MacAir and 190-200 on my iPhone and 155 Mbps on my iPad. This is with the Beryl and other devices in same room as the Comcast router.

I’m sure it will be slower on the ship but as long as the speed is adequate I’ll be fine. I really bought this device to ‘beat’ the one-login-per-room restriction,

Thanks for all the help. The beta install “did the trick.”

@dev77 I have Comcast as well and get 750-800mbps to my Macbook Air. I now get ~350mbps with the Beryl MT3000! It will vary with how far you are, but you should get over 250-300mbps at a minimum I would think.

Glad the beta fixed it! It seems like the beta upgrade → reset fixed it for me. The beta didn’t seem to “take” by just updating it. I had to do a reset first for it to work.

1 Like

I had the same issue. I couldn’t get faster than 20 Mbps on my GL-MT3000. When I downgraded from the latest beta to the latest stable, that fixed it for me.

4.2.3 is broken; terrible wifi 5ghz speed!

I had terrible speeds as well after the upgrade, but after a factory reset it started working fine. Annoying but worth giving it a shot.

Thanks I reset it using the admin panel but still is very slow. At the hotel I am at now the Beryl is sat next to my Mac and it gives me 280Mbps connecting an ethernet cable to the Beryl AX; and Wifi 5Ghz to the same Beryl AX right next to the Mac gets me around 25Mbps on 4.2.3 :sob:
Connecting an Iphone or iPad to the Wifi yields the same 25Mbps, no idea why as the signal strength is great.

set the bandwidth of the Beryl to 160Mhz, I saw that you have it set to 40mhz. You can find this setting under wireless

81/82 (Mbps up/down). GL.iNet GL-MT3000 v4.4.6 5Ghz Repeater.

594/328 (Mbps up/down). Google Nest Wifi.

I gave up on this device… or maybe my expectations are invalid.

When downstairs in my office where the Comast router is, my iPhone gets 400Mbps (not using Beyrl).

When downstairs in my office using Beryl 8 feet from router, my iPhone gets 209 Mbps .

When I’m upstairs my iPhone gets about 150 Mbps from the Comcast router (not using Beryl).

When I move the Beryl upstairs with my iPhone I get 75 Mbps.

I thought that the device might work as an ‘extender’ that would increase speed upstairs, but it doesn’t. So if you are expecting what I was expecting, you will be disappointed.

The only use of this device is to be able to connect more devices to one router… like in a hotel room where connectivity is limited. I understand ‘some’ loss but not as much as it is… 50%.

1 Like

Not if they use a different channel for the backbone connection, as any decent AP should! I hate to shill for UI, but all of my ui Wi-Fi extender boxes seem to use a different channel for the backbone connection and give FULL bandwidth to all clients.

My goal with this GLInet box was too have one box that would give me all the options in a low power portable device. I want to be able to set it up as a Wi-Fi extender, a straight AP connected to an ethernet cable, and even a full router with NAT, VPN, etc.

I certainly don’t expect this tiny box to be able to keep up with a 1.5G x 1.5G Service while in full router mode, but it doesn’t seem unreasonable to expect at least 100x100 with near zero packet loss or jitter in ALL modes. I am getting 0.02kbps up stream and so much data loss that I can’t even load a modern webpage!! :rage:

My next test with the ax1800 will be to run an ethernet cable from the ISP router to the ax1800, configure it as a plain jane access point aimed down the hill where I shall attempt to connect to an Asus router in “wifi extender mode“. I’m actually much less concerned about the SPEED, than about the lost packets and jitter. I just need a reliable connection down the hill.