Extremely slow Wi-Fi speeds using repeater on GL-MT3000

I just purchased a GL-MT3000 on Amazon and updated the firmware, connected to my 5ghz Wi-Fi 6 router and I’m getting 10-15mbps. The Wi-Fi 6 router is 8 feet from the MT3000 and I have 1.4gbps download speeds and can easily get 800-900mbps from devices in the room. I’m using all default settings (aside from deactivating 2.4ghz) and no matter what I do can’t get over 20mbps while my phone, tablets, and other devices can easily get 800-900mbps when connected directly to my router. This seems like a bug or maybe I’m missing a setting that needs to be configured? I also saw a few complaints on Amazon about not getting over 20mbps “with the new firmware update”. So is this a bug and/or known issue?


1 Like

I hard wired it to the router and still am only getting 125-150mbps with devices ~1 foot from it over 5ghz.

What firmware version are you currently using?Can you please try the beta firmware on June 3rd?

I was running the stable 4.2.2 version. I just updated to the 4.2.3 beta version and it did not appear to have any effect. I’m still getting very low speeds (~15mbps). Oddly enough, the upload speeds are close to my max (~35mbps). Any troubleshooting would be helpful!

  • I also appear to be getting significant download jitter and >1% packet loss. Something is definitely wrong.

The packet loss rate is also abnormal, can you share your WIFI configuration?How about bandwidth and channel?

I have been testing with the following setups:

3 different routers:
TP-Link AX1800 Wifi 6 Router
Asus RT-AX86U Wifi 6 Router
Older Asus RT-AC68R

Using repeater mode with all three they all exhibit the same slow download speeds (not upload). All using 5ghz and various channel/channel width settings. I don’t think the issue is from one of these three routers.

I’m using an iPhone, iPad, and Windows 11 desktop over wireless to connect to the GL-MT3000 to test. The wifi configuration for 5ghz (2.4ghz is deactivated) is TX Power = Max, WPA2-PSK security, and 11ac/ax (tried a/n/ac/ax but no different). When in repeater mode you can’t change the bandwidth or channel.

When using various speed tests I receive incredibly high download latency/jitter (~8075) and ~>1% packet loss. This is on all 3 devices connected over 5ghz and within 3-4 feet of the GL-MT3000.

Update: I just ordered a GL-AXT1800 and it will be delivered in a few hours. I will run the same tests. I’m leaving on Saturday for a trip and will be testing out various travel routers until I find one that works.

Ok, looking forward to the results of your next test.

MT3000 on 4.2.3r1 from 06/03, repeating over 5G to a NOS router with a 500/100 connection, I’m seeing 320/105 on a W11 laptop about 20 ft away.

So, normal here.

Repeated my tests but disconnected all other devices first from the TP-Link (other than the two testing devices). I have a 1.5gbps fiber connection. Slightly better results this morning but still not happy.

TP-Link AX1800 Wifi 6 router connected to MT3000 via repeater over 5ghz (3 feet apart). Both the iPad and Windows desktop are 3-4 feet from the MT3000.

SpeedTest.net Results:

Windows 11 desktop direct to AX1800: 756mbps

iPad Pro direct to AX1800: 779mbps

Windows 11 desktop connected to MT3000: 52mbps

iPad Pro connected to MT3000: 59mbps

I received the GL-AXT1800 Slate last night and will run the same tests today. Hoping for better results!

I tested the GL-AXT1800 Slate with the same setup and am getting significantly better results!

I’ll do some further testing today, but mostly likely I will return the MT3000 and keep the Slate.

Update: No idea what’s wrong. I tried both the Slate and the Beryl in a variety of scenarios and the Slate is consistently 4-5x faster in all tests on all devices. This appears to be some limitation or software issue with my Beryl unit.

I have a 2 month old Beryl from Amazon. Normally I get 600 Mbps down via the new (white) Comcast wi-fi router to my one year old MacAir.

I unboxed the Beryl today, did the setup but the Beryl can’t get above 80 Mbps down (using Ookla) and I’ve done everything you can imagine to get this thing to work.

I planned to take it on a cruise ship next week so I thought I better test it out. I’m going to have to pitch it and get something else… not sure what.

Unless someone can come up with a good idea, I’m going to give a 1-star review on Amazon and move on. Very disappointed.

Did you update the firmware to the latest beta?

What is the performance of 2.4G WIFI?

I did the “online” firmware upgrade to the current stable version, not the beta 4.x. Since I’m leaving in a few days, I’m wary of a beta version as I don’t have time to test it and don’t know how I would revert back if necessary.

I do not have the 2.4G active now because it was only about 40 Mbps, half of the 80 Mbps I got with the 5G version.

I’ve rebooted at least 25 times and have tried all versions of security protocols. Nothing gets me above 80 Mbps with Fast as well as Ookla and Xfinity test sites.

I am not expecting the 600 Mbps and would understand around 200 Mbps… but not 70-80… unless maybe that what you get.

What is the metric for a good connection? I’ve heard taking top speed from ‘direct’ wi-fi and dividing it by 4? That should give me at least 150 Mbps? Is there a formula to estimate resultant speed?

I’d sure love to keep this little router but I don’t know what else to do. I’m a software engineer with many years of experience with stuff like this, and this has me baffled.

I would not think my Comcast router would be throttling but who knows?

It seems you are bridging all hardware routers via WIFI.
Bridging two routers via WIFI will cut speed in half.
You can imagine 50% of the bandwidth is used to communicate between routers, and another 50% bandwidth is used to communicate with devices.
There are only two antennas on GL-MT3000, so functions like MUMIMO will not be available or harmed.
So you will see there should be a “separated backhaul” for the “mesh system”.
I am not an expert on this, but the above is my understanding.

Hi Dev77,4.2.2 firmware has an issue affecting wifi speed, this issue has been fixed in 4.2.3 beta firmware, can you manually update 4.2.3 firmware to verify?

@Dipin I updated to 4.2.3 on my MT3000 and there were no changes to the speed. I’m not sure if it’s my unit or something else but I tried hard resetting and reinstalling the beta and still no changes. I can try one more time before I return the unit.

2.4ghz was slower across the board so I just turned it off and used 5ghz.

@dev77 maybe try the Slate instead? I get ~770mbps directly to the router and ~250mbps via the wifi repeater. Still not GREAT but it’s usable. My fear is going to a hotel with 25mbps and only getting ~8mbps though.

I’m also in software but not sure where to start troubleshooting on why the connection is so slow.

I’m not running the MT 3000 but the Beryl MT1300 so I’m not sure that installing a beta, which comes with a warning that says it is buggy, is going to help. (I used this thread as it was the only one I found that related. If told to start a new one, I will happily do so.)

But maybe what I’m getting (80 Mbps) from 600 Mbps is all I can expect, if the previous post by “y2kbug” is correct.

Maybe I will get the Slate, but to be honest, once burned… twice shy.

I have no idea what the speed of the cruise ship (Regent) is going to be. I got the Beryl router because the stateroom we booked has a one-login limit and I want both wife and I to be able to use the connection.

I could live with 80 Mbps, but what if you are right and the stateroom has only, say 35 Mbps… and I end up getting 7 Mbps. Sending snapshots back to friends will be S L O W for sure!

I’m guess I could try the beta today but since I’m leaving next week it might be better for me to just buy something else (perhaps a TP-Link?) and hope for a better outcome.

I need to decide today on what to do, so I hope someone can ‘rescue’ me!

Alright - no idea what happened, but I took the MT 3000 back out of the box and after another reset with the new firmware:

It seems to be much happier now:

This is closer to 50% of what i get directly to the router! No idea what happened. The MT3000 Beryl SHOULD be faster than the GL-AXT1800 Slate so this is more in line with expectations.

I’ll keep testing but I think we’re good.