File Sharing USB no files displaying

Using a mango, have followed the instructions to enable file sharing. The folder for the router appears, but shows empty (there are files on the attached usb drive). Is there an easy fix to be able to see the files?

The sharing path is correct right? Can you give some details e.g. screenshot.

Will post screenshots later as away from the router, I have followed the instructions as posted on the GL.inet tutorials, I can see the main folder, just contains nothing.


But can only find the problem via details.

can you login the router system? execute command:
ls /dev

catch the information

I’m accessing via Android, screenshots are vlc and cx file Explorer, can see folder but it is empty, any help appreciated

You can use this program on Android to access the router through ssh.

Then use the command given and provide the info needed. If unfamiliar with ssh this guide may help.

Skip down to the ssh login portion since you are using Android.

Downloaded SSH, no idea how to open a connection, and notes you directed me to give no guidance for the app?

Tap quick connect button to create a new connection. Fill in the info needed from the articles ssh section.

Edit. Forget the article, it doesn’t matter. Just hit quick connect, fill in the info for your router, probably create a new user using root as user and password you set on the router. Save all this and you’ll be able to access your router using ssh

Doesn’t accept password, says authentication error

in router system, you installed the “file share” , so it can appear “GL-Samba”。 if you USB device not recognized by router, it can’t be find in “GL-Samba” directory。

you can ssh login the router system, check the USB device whether be found.
execute command:
ls /dev

catch the information

Understand what you’re saying, all makes sense, problem is I don’t know how to SSH login to the router, the app doesn’t allow me to login due to password not being recognised.

Sound like the same problem that I struggled with for hours on both my GL-AR750S and GL-MV1000S.

Try the last post in this thread:

It worked for me on both routers.

Use the password for the router web access not what you set for WiFi access. If your password isn’t working you have other problems and should just factory reset and try again.

Information captured, any help appreciated

The router does not automount the USB drive, as it should when inserted. I tried it on my router with the same result.

Instead of using the limited GL.Inet GUI, use the LUCI GUI. Before doing that, install the luci-app-samba package under APPLICATIONS → Plug-ins, if it is not already installed.

Under MORE SETTINGS, click on Advanced to go the the LUCI GUI. Under the System menu at the top, click on Mount Points to list all your mounted file systems without having to go into SSH. The USB drive should be /dev/sda1 that is missing in your screenshot.

If so, click on the Add button to manually add the mount point in the pop-up screen. Pick /dev/sda1 in the Device box and type “/mnt/USB” (or whatever you like) in the Mount point box. Click on Enabled at the top, then go to the Advanced Settings tab and type “rw” in the Mount options box. Click on Save button to return to the Mount Points screen and click again on Save & Apply at the bottom. For me, the USB drive then displayed as mounted as /mnt/USB (or whatever you entered before).

If /dev/sda1 does not show up in the Device box, the you have to go into SSH and type the command “block detect”, which will detect the USB drive and display its UUID. Instead of picking /dev/sda1 in the Device box, pick the UUID in the UUID box.

Next, under the Services menu at the top, click on Network Shares to list your shared directories. Click on the Add button to manually add the shared directory. Type “GLUSB” (or whatever you like) in the Name box and “/mnt/USB” (or whatever you entered before) in the Path box. Clear Read-only, click on Browseable, click on Allow guests and click on Save & Apply at the bottom. For me, the USB drive then was accessible as GLUSB over the network.


What should I remove to free up space?

It seems Mango does not have sufficient storage to install LuCI. You can try configuring manually in SSH, at your own risk and without any guarantee:

  1. Connect and log into router using SSH

  2. Enter the command to detect the USB drive:

block detect

Check for an UUID should be displayed with format like “XXXX-YYYY” and record the UUID.

  1. Enter the command to add the mount point:

echo "
config mount
option uuid ‘XXXX-YYYY’
option target ‘/mnt/USB’
option enabled ‘1’
option options ‘rw’
" >>/etc/config/fstab

where XXXX-YYYY is the recorded UUID (keep the single quotes)

  1. Enter the command to mount the USB drive:

block mount

  1. Enter the command to display the mount points:


There should be an entry for /mnt/USB if the USB drive has been mounted and proceed to the next step. If not, then stop now because the mount did not work.

  1. Go to the standard GL GUI and under APPLICATIONS, click on File Sharing. Turn ON Share via Lan, turn OFF Share via WAN, turn ON Writeable. Pick /mnt/USB in the Current Directory box and click on Apply.

If everything worked, then you will be able to access the shared USB drive.


From the output, the USB disk is not recognized at all. So there is no way to proceed to mount.

Can you show the log which may display useful infomation


Amazing! Thanks for perfect instruction!