File Sharing USB no files displaying

It seems Mango does not have sufficient storage to install LuCI. You can try configuring manually in SSH, at your own risk and without any guarantee:

  1. Connect and log into router using SSH

  2. Enter the command to detect the USB drive:

block detect

Check for an UUID should be displayed with format like “XXXX-YYYY” and record the UUID.

  1. Enter the command to add the mount point:

echo "
config mount
option uuid ‘XXXX-YYYY’
option target ‘/mnt/USB’
option enabled ‘1’
option options ‘rw’
" >>/etc/config/fstab

where XXXX-YYYY is the recorded UUID (keep the single quotes)

  1. Enter the command to mount the USB drive:

block mount

  1. Enter the command to display the mount points:

mount

There should be an entry for /mnt/USB if the USB drive has been mounted and proceed to the next step. If not, then stop now because the mount did not work.

  1. Go to the standard GL GUI and under APPLICATIONS, click on File Sharing. Turn ON Share via Lan, turn OFF Share via WAN, turn ON Writeable. Pick /mnt/USB in the Current Directory box and click on Apply.

If everything worked, then you will be able to access the shared USB drive.

2 Likes