File size limit in file sharing - samba

I’m trying to set up file sharing on my MT1300. Empty 128 GB micro sd card is inserted and formatted to ext4 (r-w). I can create folders and files and also copy over network (from windows) but when file size is over 2 MB it says: there is not enough space…
Is there so small file size limit which I have to unlock or…?

make sure the directory is /mnt/sda1 not /mnt. Root is limited to 2mb.

Thanks for reply.
I have checked it another 100 times and the limit is 13 mb. I can copy to the router as many as I want files below 13 mb but one by one only. Micro sd card is mounted in /mnt/128gb/

1 Like

I have exact same problem on my MT1300, and tried both an SD card & a USB HDD (both formatted as NTFS).
It cannot copy files bigger than 13MB, but anything below that is fine.
Did you find a solution?

Can you show output from the following commands in SSH?



block info


I managed to find a workaround by mounting “/mnt/mmcblk0p1”, and not just “/mnt”.
“/mnt” seems to have the limitation (of 13MB), but not when I mount the drives directly to share folders.

Here is the output of the commands, but “block info” wasn’t recognised:

root@MyRouter:~# df
Filesystem 1K-blocks Used Available Use% Mounted on
/dev/root 14592 14592 0 100% /rom
tmpfs 126564 5984 120580 5% /tmp
/dev/mtdblock6 15936 4028 11908 25% /overlay
overlayfs:/overlay 15936 4028 11908 25% /
tmpfs 512 0 512 0% /dev
/dev/mmcblk0p1 125534240 68241152 57293088 54% /mnt/mmcblk0p1
/dev/sda1 156287996 15375120 140912876 10% /mnt/Ext_160GB
/dev/sdb1 156287996 15375124 140912872 10% /mnt/Ext_160GB
root@MyRouter:~# mount
/dev/root on /rom type squashfs (ro,relatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,noatime)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,noatime)
cgroup on /sys/fs/cgroup type cgroup (rw,nosuid,nodev,noexec,relatime,blkio,devices,fr eezer,net_cls,pids)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev,noatime)
/dev/mtdblock6 on /overlay type jffs2 (rw,noatime)
overlayfs:/overlay on / type overlay (rw,noatime,lowerdir=/,upperdir=/overlay/upper,wo rkdir=/overlay/work)
tmpfs on /dev type tmpfs (rw,nosuid,relatime,size=512k,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,mode=600,ptmxmode=000)
debugfs on /sys/kernel/debug type debugfs (rw,noatime)
/dev/mmcblk0p1 on /mnt/mmcblk0p1 type vfat (rw,relatime,fmask=0000,dmask=0000,allow_ut ime=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,utf8,flush,errors=remount-ro )
/dev/sda1 on /mnt/Ext_160GB type fuseblk (rw,relatime,user_id=0,group_id=0,allow_other ,blksize=4096)
/dev/sdb1 on /mnt/Ext_160GB type fuseblk (rw,relatime,user_id=0,group_id=0,allow_other ,blksize=4096)
root@MyRouter:~# block info
-ash: block: not found
root@MyRouter:~# blockinfo
-ash: blockinfo: not found

Your microSD card is mounted on “/mnt/mmcblk0p1” that you are able to share.

Your USD hdd is mounted on "/mnt/Ext_160GB so you can try sharing it,.

“/mnt” is the internal storage of the router that only has 13MB freespace.

I used the LuCI GUI to set up multiple file shares because the GL.iNet GUI only shows 1 directory to be shared, which is confusing to me.

You may have to install packages for the “block info” command. Here is more information:

1 Like

Yes, the GL-iNet interface is limited, and I was using the LuCI GUI to define 2 different shared folders/mounts, and that seems to have worked fine so far. I had to install the plugin “luci-app-samba” (git-21.044.30835-34e0d65-1) to be able to do these modifications.

Your comment of “/mnt being the internal storage with only 13MB free” makes sense now, and I believe that’s why even when I was in “/mnt/mmcblk0p1”, I still could not copy files bigger than 13MB (with only “/mnt” being mounted).

Thanks a lot for your support!

1 Like

As I remember, and it was a while ago, I formatted it again, but to fat32, and then again to Ext4, but on my Ubuntu or Android, not sure, but it works now.

hello, you use samba, into GL-Samba/mmcblk0p file floder, can copy the file bigger than 13MB ? is goto GL-Samba/mmcblk0p, Not in GL-Samba file floder