Filesystem Mount Issue with GL-XE300 Puli Router Running OpenWrt


I’m encountering a filesystem mount issue with my GL-XE300 Puli router running OpenWrt. Below are the details of the problem:

Issue: The device fails to boot properly and reboots repeatedly. Upon booting, the following error message is displayed:

[    2.039932] /dev/root: Can't open blockdev
[    2.044179] VFS: Cannot open root device "(null)" or unknown-block(0,0): error -6
[    2.051973] Please append a correct "root=" boot option; here are the available partitions:
[    2.060617] 1f00             256 mtdblock0
[    2.060621]  (driver?)
[    2.067375] 1f01              64 mtdblock1
[    2.067378]  (driver?)
[    2.074140] 1f02              64 mtdblock2
[    2.074144]  (driver?)
[    2.080915] 1f03            4096 mtdblock3
[    2.080918]  (driver?)
[    2.087669] 1f04           11904 mtdblock4
[    2.087672]  (driver?)
[    2.094434] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
[    2.102975] Rebooting in 1 seconds..

Description: The device is unable to mount the root filesystem, resulting in a kernel panic and continuous reboots.

Device Information:

  • Model: GL-XE300 Puli router
  • Operating System: OpenWrt

I would appreciate any assistance or guidance on resolving this issue.

Hey :wave:

looks broken to me, but if you are lucky, it’s just the file system itself.
Try to use Uboot to Debrick: Debrick via Uboot - GL.iNet Router Docs 4

If this fails as well, it might be broken and needs to be replaced.
Since you wrote you are using OpenWrt the debrick guide might not work, in that case you have to debrick like the OpenWrt guide says.

Did you flash your own firmware?
If yes, which one?

Hi @admon,

Thank you for your reply!!

I have tried to Debrick via Uboot but it does not help me. Also, I will try the method that you have shared for OpenWrt.


Hi @alzhao,

I have flashed the custom OS based on OpenWrt v22.

It just seems a wrong firmware problem. Did you download the firmware from anywhere?


Based on the OpenWRT v22.03, I have customized the firmware, and it seems some file system issue.

Do you have two files, one .img, one .tar?

@alzhao, I have .img and .bin

Use .bin to upgrade in a working openwrt and use .img in uboot.

Normal upgrade with .bin file does not work. So, I was trying for uboot method with .img file. But still the issue remains.

Scenario Performed:

  • Flashed the latest standard firmware (4.3.7) from GL-inet website. Using uboot method, upgraded the device (worked)
  • Later, tried with my custom OS on top of the standard OS using uboot method but did not work.

Sorry it should be a .tar file to use in normal openwrt update. Do you have it?

@alzhao, I do not have a .tar file in my custom build.

Can you give as screenshot of what you have in your firmware folder after compile?

@alzhao, attached is the snapshot of the files generated after the build.

How can I get the SPI-NAND chip model information used in the GL router XE-300 puli?

I am not sure why this is needed.

The sysupgrade.bin should work as .tar file which we used. But if it does not work, can you give us more info?

You can email us: support at about details if you don’t want to disclose here.