Firewall bug found on flint firmware 4 beta release 2

Hello there,

I just want to report a small bug for the firewall in the new beta firmware 4 release 2 from github for the flint.

It seems when I try to port forward port 61455-61458 it gives me a error with 1 ~ 65535, since I think this one might be forgotten I report it, as for other bugs I have not found any yet it seems to work smooth for me.

Can you post the GitHub link? I’m using the v4.0.0 also beat8 that was posted on this forum… Disappointed that VPN client & server cannot be active together - #12 by alzhao?

Hi there,

Sure I can!, Its here, you need the ax1800.tar.gz, this has the sys upgrade aswell.

You have to extract them first :+1:



This is the file “openwrt-ipq807x-glinet_ax1800-squashfs-sysupgrade.tar”? Is it safe to keep settings? (want to avoid bricking it, etc… )

Yes its the tar file with upgrade in the name, I tried this on beta 8, and it works fine :+1:

1 Like

Do you know whether this build includes a working version of SQM with Cake?

I have did a quick look but it seems if I use the current opkg list kmod-cake-sched fails to install, but on that github link there is also a kmod all tar file and a gl-inet ipk tar file, maybe its in there…

since it says its for 1800axt I think you could still install it on the Flint since its the same soc unless said ipk targets something very specifics which is not in flint.

I can intall the packge. So supported?

1 Like

When I tried to install it, there was a dependency package that was missing.

can you output this file here?:

cat /etc/opkg/distfeeds.conf

I got here:

src/gz glinet_core
src/gz glinet_gli_pub
src/gz openwrt_base
src/gz openwrt_luci
src/gz openwrt_packages
src/gz openwrt_routing
src/gz openwrt_telephony

I wasn’t able to install it at first but now I was, but I don’t know why it didn’t found the package before for the cake kmod.