Firmware 3.105 Snapshot Update

3.102 has broke 300 MBPS connection ability for Microuter N300. 3.025 was 300 Mbps.

Hope you build again that it support 300 Mbps.

any chance to have ar750s 3.105 whit AdGuard Home v0.104.1 and same on brume w.

WireGuard policy routing kills new connections to WiFi if WireGuard goes down even when it is set to Domain/IP and kill switch disabled. It also kills DNS over TLS (NextDNS).

We should also be able to send device name to NextDNS. I probably can do this manually if it is still using stubby but would be much better if the GUI has a field for it.

Actually as I suspected. All issues are caused by Stubby. Stubby does not seem to work good with NextDNS. At least not the version used by GL-iNet.

AdGuardHome was much better but unfortunately the AdGuardHome build was removed from GL-iNet servers and I don’t have a backup of it to revert to it!

Which model are you using?

In 3.105 you should be able to set up NextDNS ID if this is what you mean. I can test if stubby affect vpn policy.

Convexa-S. Stubby crashes every around 4 hours. Same issue that I had with older firmwares too when I edited stubby manually using ssh. AdGuardHome never caused me any issues but I can’t find the image for the firmware now at all >.<

Any chance you got a copy? Please! >.<

Pls allow to fix. S1300 just added 3.105 and too many bugs。

Noticed a new build was pushed. Installed it. NextDNS is no longer available and I really need that for my setup :confused:

AdGuardHome was working amazingly well with NextDNS to be honest. I hope we see it again.

Hi Alzaho,

Thanks for the amazing work you put in for keeping the GL.INET Devices update with latest features.

Biggest issue that I’ve been facing with S1300 since v3.102 is PPPOE Connection Issues, PPPOE is completely broken after v3.100

Cannot connect to the Internet with PPPOE from Firmware Version v3.102 onwards. Last working version is v3.100, tried the latest Snapshot v3.105, the issue is still there.

This is what happens and PPPOE doesn’t work so no Internet Access is available.

• Sent 50 bytes, received 28 bytes.
• Sent PADT
• Exit.
• Plugin loaded.
• RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
• pppd 2.4.7 started by root, uid 0

• Plugin loaded.
• RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
• pppd 2.4.7 started by root, uid 0
• PPP session is 1

Are you saying this is 3.105 specific, as I use Stubby for NextDNS (AR300M, 3.104) and it works flawlessly.

I’ve tried various builds of 3.105 on a AR300M and seem to be experiencing “memory leak freeze”
If I stress the internet (USB mobile broadband) by downloading on several connected clients at the same time, everything grinds to a near halt. If I then cancel the downloads, the internet does not recover, necessitating in a reboot of the router.
Any advice on how to troubleshoot the problem?

I have been trying NextDNS via Stubby on many past firmwares and the very current one but Stubby always crashes every few hours.

This was never an issue for me when I used AdGuardHome in the snapshot build that was released a few months ago. It was the most stable build.

3.105 makes it way worse because when the router stops DNS resolving it seems to drop WireGuard (or WireGuard drops first) which then stops access to any new device over WiFi or Ethernet and the internet stops on any device depending on the router for DNS like my Roku or Apple TV.

Sounds like your issue might be related to mine (posted just above)?
(I use both Wireguard and Stubby)

Could be. This is frustrating to be honest. I would revert to the AdGuardHome build if I could but I no longer have it and they seem to have removed it from their servers. No idea why! >.<

@MRizkBV Check PM, i sent you a link :slight_smile:

1 Like

I really appreciate it!

Are the “Bug Fix” items that are outstanding or have already been fixed?

I see in new Snapshot folder
firmware/snapshots/20201114/ar750sm16 and ar300m16

What is m16?

Thank you.

are these firmwares still based on outdated old version of openwrt?(mt300 v2 mango)

David : M16 refers to the models with “16MB Nor Flash”. If yours doesn’t have that in the model number (check the sticker on the device), then it’s not the correct version for you.

@gaflarf : I can confirm that, at least for my AR150, the 3.105 snapshots are still based on an older OpenWrt tree:

OpenWrt 18.06.1 r7258-5eb055306f / LuCI openwrt-18.06 branch (git-18.196.56128-9112198)

@alzhao : FYI, the snapshot for my AR150 writes the following line into the system log every ten seconds:

Sun Nov 15 10:05:51 2020 user.debug : Function:get_tertf Line:718 Open /tmp/tertf/traffic_info_bak Fail!

1 Like