Firmware 3.212 - smartsnmpd provides no interfaces

I just upgraded on 5 of our 6 our GL-B1300 routers from 3.105 to 3.212.
After that, noticed my MRTG graphs for all those routers no longer would update.
I ran snmpwalk from the MRTG system, and it receives a response from the routers indicating that there are no interfaces:


net-snmp.snmpwalk -v 1 -c public -L eo

SNMPv2-MIB::sysDescr.0 = STRING: Linux router 4.4.60 #1 SMP PREEMPT Wed Mar 24 18:00:04 CST 2021 armv7l GNU/Linux
SNMPv2-MIB::sysObjectID.0 = OID: iso.2.3.4
DISMAN-EVENT-MIB::sysUpTimeInstance = Timeticks: (144700) 0:24:07.00
SNMPv2-MIB::sysContact.0 = STRING: Me
SNMPv2-MIB::sysName.0 = STRING: router
SNMPv2-MIB::sysLocation.0 = STRING: Shanghai
SNMPv2-MIB::sysServices.0 = INTEGER: 72
SNMPv2-MIB::sysORLastChange.0 = Timeticks: (144700) 0:24:07.00
SNMPv2-SMI::internet = No more variables left in this MIB View (It is past the end of the MIB tree)

It appears smartsnmpd is not working on firmware version 3.212.
Can you fix this?

Additional note: I just tried reverting back to 3.105, and doing that breaks wifi. So now I have the choice of having snmpd functions, but no wifif, or having wifi, but no snmpd functions.

Please fix this.

Why there is no wifi?

Pls note, if you go back to older openwrt, do not keep settings.