Firmware 4.50 for FLINT Router available

BIG Upgrade

V4.5.0 - Oct 09,2023

Added Bark parental control feature.


Fixed the issue where blacklist configurations were not synchronized when upgrading from low versions to 4.4 or later versions.
Fixed the issue where security options were missing when upgrading from version 4.4.x to 4.5 using reserved configurations.

Full Cone NAT

Added Full Cone NAT functionality.


Optimized LAN function to support switching DHCP on/off and configuring common DHCP parameters.
Decoupled internal and guest networks IP addresses and DHCP functions, allowing independent configuration of DHCP servers.


Added support for IPoE, including DHCP and static dial-up with VLAN ID configuration.


Restructured mwan3, renamed it as kmwan.


Added community-based language packs, allowing users to manually add them.


Adjusted SMS functionality.
Supports EM060K upgrades.
Fixed the issue where the TTL setting does not take effect.
Fixed the issue where B66 and B71 bands are locked incorrectly.
Fixed the issue where the TTL setting does not take effect when using 3G protocols.


Added additional multi-sign-on restrictions.


Fixed a security vulnerability in NAS.
Fixed issues with user deletion and shared folder deletion that were abnormal.

Parental Control

Optimized parental control logic.
Fixed the issue where Failover is not effective when enabling parental control under the 'drop-in gateway' mode.


Fixed the issue where continuous DFS scans occur when all interfaces are turned off.
Fixed the issue where WiFi restarts itself repeatedly when operating in a DFS channel as a repeater.


Added RS485 functionality.


Fixed RTTY abnormal disconnection issue.


Added new Security configuration page.


Fixed OpenVPN encryption issues by adding support for 'askpass' to authenticate users in configurations.
Optimized VPN Dashboard by adding a switch for client-to-client communication when using WireGuard servers.
Optimized failover handling when switching between VPNs.
Optimized OpenVPN to support TAP S2S mode.
Added a method for deleting VPN account passwords.
Fixed an issue where setting an OpenVPN configuration would prevent access to the VPN server's WAN port.
Fixed DNS leak issues.
Fixed an issue where VPN configurations were not applied correctly after enabling VPNs.


Added a new network advanced setting in the frontend.
Updated language files and pulled in updated translation scripts.
Display the 'OpenDDNS' button only when the 'Enable DNS' option is checked in the settings page.
Added Bark translation and updated the parent control UI.
Added rs485 UI and translation.


Added gray testing design, and added RC version subscription and upgrade.
Optimized upgrade status and timeout time.
Fixed interface errors.


Fixed the issue where WiFi failed to start for the first time after upgrading.
Added temperature protection settings.

This morning I discovered that my OOMA VOIP service was NOT working after having flashed to Firmware 4.50 on the Flint router. I powered off/on the OOMA Telo VOIP Adapter to see if that made a difference. It did not…I tried enabling the SIP ALG Feature on Firmware 4.50 to see if that made any difference. It did not.
Twice I flashed back to version 4.46 and restored settings and each time I went back to Firmware 4.46 my OOMA Voip Service would work again. And each time I went back to firmware 4.50 on the FLINT my OOMA Voip service would not work.

OOMA VOIP is one of the most widely used residential VOIP services in the U.S.
For GL.inet’s reference OOMA states it uses the following ports.

remote UDP/TCP 53, 1194, 1294
remote TCP 80, 110, 443
remote UDP 67, 123, 3480
local UDP 49000 to 50000
remote UDP 10000 to 20000

So I’m back on firmware 4.46 and my OOMA VOIP service is working again. Some change in 4.50 is not compatible with the OOMA VOIP service.

Hello, is there any configuration for voip in version 4.4.6? If so, please keep the same configuration as 4.4.6 in version 4.5.0.Then test again, note: do not enable sip alg on 4.5.0.


There’s no VOIP configuration (No addons) in 4.4.6. I did NOT enable sip alg when I first tested 4.50. I only enabled it as a test after I found 4.50 not working with OOMA and when I found it did not work enabling it I disabled it again as was the original case. If you have an updated build to test of 4.50 let me know and I’ll test it with OOMA and let you know how it goes. Right now I am back on 4.46 and OOMA VOIP service is working (Like I said I tested it twice by installing uninstalling and both times I found 4.50 from yesterday would kill OOMA VOIP service and reinstalling 4.4.6 and restoring settings would return OOMA VOIP to working.
Let me know if you have an alternative updated build of 4.50 to test. Thanks.

Hello, I have compared the differences between version 4.4.6 and version 4.5.0. The two packages of ipt-ipopt and ipt-conntrack-extra were cancelled in version 4.5.0. Could you please test them again after installing these two packages in 4.5.0?Similarly, sip alg does not need to be enabled.

OK…I did test openwrt-ax1800-4.5.0-1010-1696887780.tar once again but again it killed OOMA VOIP Service…I just got everything working again on 4.46…I will install 4.50 once more and then install
the two packages you requested and will report back if that solves the issue.

I’m finally back…
Well _zhang…There’s a reason they removed ipt-ipopt and ipt-conntrack-extra from 4.50…
I installed 4.50 for the fourth time…And confirmed that for the fourth time it killed OOMA VOIP Service. Then I attempted to install ipt-popt and ipt-conntrack-extra plugins from the gl-inet repository…ipt-popt installed without issue…Then I attempted to install ipt-conntrack-extra…That completely locked me out of the gl.inet interface. I attempted to get back in by powering on/off…Nope…I was locked out of the interface…
I finally had to unhook the Flint Router and bring it to a local PC where I then did a reset so I could get into UBOOT where I then was able to restore 4.46 .img file…After that I restored 4.46 settings from my saved .tar.
And I am back on 4.46 and have OOMA VOIP working again…I am done for the evening.

I just tried it, and it’s exactly what you said, when I tried to install ipt-conntrack-extra, the router crashed.This seems to be a bug with the snapshots 10.10 firmware. It doesn’t appear in the October 9 beta.
GL.iNet download center (

Decided to try the 10/9 Beta again…It immediately stopped OOMA VOIP from working…But then as you said I was able to install both ipt-popt and ipt-conntrack-extra in the 10/9 Beta without issue…I rebooted the router and the OOMA VOIP adapter but unfortunately the OOMA VOIP service still did not work so it appears that those two packages are not the problem…I would be looking at the reworked MWAN (Kmwan) as the possible culprit. I’m back on 4.46 and OOMA is working again. Good night.

I made some modifications based on the 10/9 Beta version to try to fix this problem, but I don’t have an environment here, could you please help verify it?If you are willing to help, you can tell me your email address by private message, and I will send the firmware to you by email.Thank you very much.

I sent you my email via private message.