Firmware V3.005, Added firewall and QoS


#1

Dear All,

Pls try firmware v3.005 which added Firewall and QoS bandwidth limiting.

Please go to http://download.gl-inet.com/firmware/ and find your model then “testing” folder to download.

QoS bandwidth can be set up in “Clients” page.

Firewall is in a separate page.


GL-AR300M port forwarding NOT saved and applied
#2

ar750s - In the clients section, something is wrong… clients appear and disappear, as if it only showing clients with active transmission.


#3

Mifi - Auto set up of Tmobile SIM, worked perfectly. on Speedtest.net I get 22 ms ping, 33 Mbps Down and 33 Mbps Up. 10-12 Mbps better than previous firmware.

New interface is nice, however when clicking on the last menu item, no scroll bar shows up to scroll down on my Laptop screen. I have to click and “drag” down the menu to get to it. It should either use the right most scroll bar, or have its own scroll bar.

I tried to go to \192.168.8.1 from filesystem window, then click on sda01 and I receive an error connecting. This is on Windows 8.1 64 bit, Intel Celeron Dell Laptop. On my custom built Core i5 with Windows 7 Pro and old firmware, I was able to access files in the same manner. I can try that tomorrow night.

Opening screen to enter admin password and choose language seems to not be rendered correctly, spacing is off.

Looks great though! I love the diagram showing all the connections. I will try the wireguard server at some point.


#4

Is this for all models? I can’t see it for AR300M.

Glitch


#5

Not yet for AR300M. But it will be updated soon.


#6

This is a cache issue. Clear the cache of your web browser and you will see the scrollbar.


#7

I updated my AR300M and all looks good…I didn’t have any of the issues from before, but this time I am on OSX using Safari. I did notice one thing…you removed the switch function to be able to toggle between BRIDGE (Access Point) and ROUTER mode. This is actually a feature that my IT friends like so be able to use this as a diagnostic tool working on switch stacks etc.

Other than that…the interface and operation looks good.


#8

Now you can change network mode in the UI. But you need to use reset button and press 3 seconds to revert to router mode. It is not so convenient as using the switch button but it is less confusing.


#9

I actually didn’t find it confusing at all…I use it at work to switch between bridge and router mode to connect to a closed network we have for dedicated audio/visual equipment. Very easy and less steps then logging into the UI to change the mode. I am hoping you see it clear to add that back to the menu of options for the switch :slight_smile: . I do understand the quick VPN on/off functionality being good for the “travel router” folks…but if the option could be added back, that would be great, and a some of my IT people were looking to purchase these basically for that functionality and the internal antenna model.


#10

On v3.0 firmware, you can switch to router mode by holding reset button, or you can find its IP address on your upstream.

It will cause a lot of issues if using a slide switch to control bridge or router mode.


#11

Ok, I understand, but it is something that WAS working on the 2.27 version…I demonstrated it to people…you had to power off, switch then power back on…but that is easy enough…

Rest of the update looks good.

-Mike

#12

Are we at a point yet were we can just opkg update the GL packages without having to reflash for each release?


#13

Just update gl ipks would cause a lot of issues, upgrade firmware directly is recommended.


#14

When do “Test” firmwares become available through the Online Upgrade? Is that when they are considered stable. I upgraded both my 750S and USB150 to 3.005 but not sure when your firmwares are considered stable releases. Find the USB150 is more stable than my 750S as that one still disconnects in the office that has WPA2 Enterprise.


#15

This is an issue in firmware which is a cause of my window error.I have tried to solve but I could not find a solution.Window error 0x8024200b is give me good solution and they say to use updated firmware


#16

@CassieGriffin

This not related to the router firmware in any way. Either a windows wifi driver issue or some other problem.


#17

Do you plan to release for b1300 as well? It seems is not in the testing/ folder at the moment


#18

Answered you in the other thread.


#19

jardon you need to rephrase the question.
“When will the B1300"also get a testing version and why is the B1300 always treated like the ginger haired step child when it comes to firmware?”"

The B1300 is the most expensive of the GL-INET devices one of the newest and still it feels like development for it is an afterthought. It should be the first into testing and release not the last.


#20

The reason why the B1300 doesnt get updates that fast is because the entire build system and drivers have been closed source for a long time. If the toolchain is stuck on OpenWRT CC, there is not much you can do.

Remember that devs are dependent on the tools from Qualcomm to compile anything in the first place when the system is not completely open source. The open source drivers for the Qualcomm chip used in the B1300 have only recently been deemed stable. When drivers are closed source, they are stuck to a specific kernel version, which in turn means it is stuck to a specific OpenWRT version too.

The MTxxx routers have a similar issue.

Other GL routers that you see lots of updates for have been open sourced by Qualcomm for a longer time, so the devs have the freedom to run the latest OpenWRT and so on.