Firmware V3.1 in testing page for 6416A - UI problem & Test reports

I was quite happy to see beta firmware V3.100 for my old 6416A on testing page. I flashed it directly to find out if it would be as good as in AR300M.

Flashing firmware was successful but the main page were frozen. I could not open any options there and the router image itself was not 6416A, but a mifi I guess.

Could anyone here successfully flashed and tested this new firmware? What is the right procedure to flash this, do I need to do exroot because of small memory?

It looks like the problem only in Internet Page, other pages are working fine. I managed to go to Scan wifi by closing the current page in browser and directly go to address :
Every time UI freeze I do the same and it is always working. Only Wireless page is still failed to load and need to be set using terminal.

Due to small RAM and ROM size, I added exroot to add more space and little bit stability because of Swap. Some notes for this beta:

  • Wireguard is working very well. I use my own vpn in gcloud which had problem in previous stable version.
  • VPN policy improved, much more stable compared to previous version

… I will test other things later.

But I really appreciate this beta for old router like 6416A. Thanks

Is the frozen problem caused by browser cache? Or exroot?

It is always frozen even after flashing and not yet exroot. Only Internet and wireless page that frozen, other pages are working fine. I wonder if this caused by browser cache, I used phone browser and laptop browser, all with same result.

This product is no longer maintained.
But I have updated the firmware for you to solve this problem. you can download from GL.iNet download center and test it. Thanks.

Thanks a lot!
That’s update solved my problems. I really appreciate your support for this old device.

I tried this firmware, I see it’s the new UI interface
but now my web ui is not responding anymore when I click on the left panels
is this expected? what should i do?

from the browser dev tool I can see it kept having this error

TypeError: Cannot read properties of undefined (reading ‘interfaces’)

it fails at this getWifiList function, i can’t access the GUI, is there anyway to fix this?

edit: sorry for posting this without doing a full wipe reset first, after reseting and remove all previous config and setting and do a clean firmware flash, everything now works, finally i can use wireguard on this old router

1 Like