First time user, setting up -- cannot get to admin panel

Hi there,
I just bought a GL-Inet MT1300 Beryl travel router. I am setting it up for the first time. I am following the instructions on this page: First Time Setup - GL.iNet Router Docs 4

So the first thing I did is plug in it, then change my wifi connection to the router’s SSID (GL-MT1300-118), using the default wifi network password “goodlife”. So far so good.

Next I tried going to to set up my router’s admin password… but got stopped because apparently there’s already a web admin password set up, and it’s not “goodlife” nor “admin”. There’s no option to select a language or anything yet. Why is there already a password set up? According to the 1st time setup instructions, I’m supposed to create one. Again, this is a brand new router and I’ve never used it before.

I tried holding the router’s reset button for 10 seconds like it said to reset, but after waiting for it to reboot, the web admin panel page still asks for a password. Not sure what to do… any help please??

Again, the instructions say, “There is no default password for the Admin Panel. You have to set your own password, which must be at least 5 characters long. Then, click Submit to proceed.” but this is not true… there is some sort of password already, and I didn’t set it up. Thanks for any insight!

By the way I’ve tried doing this on both Firefox and Chrome on my Mac, if that makes any difference.

Sounds like you could have received a faulty returned unit misold to you as new. I would return it to the vendor if I were you.

I bought it off of Amazon. :frowning:

So I guess holding the reset button does not reset everything, specifically the web admin panel… oh well.

It does usually.

You can try the debrick method although as I said, you have been likely sold a returned unit and l would return it to Amazon. Exact same thing happened to me with one of the GL.iNET routers that I bought.

Maybe you can pm me your purchase channel and order ID.

Some people bought OEM version from someone else and they configured everything.

If it is our firmware the reset for 10 seconds should clear everything.