Flint 1800 Beta 4.2 hard disk problem (Samba or FTP)

Hello everyone I have the Flint 1800. with the firmware version 4.2 beta which also runs well.

I have the following problems. If I connect a hard drive, it is also recognized and displays everything. Also the appropriate settings are made (samba) with write permissions and user assignment.

But no matter what PC (Mac or Windows) I can only read but not write and I can not find the error.

I tried to reboot and reinstall everything without success. Connected to the PC I have full access to the hard drive with read and write permissions.

No matter what I try I can not move data on it only read.

On Mac there is no error message except the familiar crossed out circle that it doesn’t work and on Windows it says I don’t have the right to move anything to the hard drive.

Oh yes almost forgotten. With FTP can be enabled but access via wan or path sharing do not go to enable at all

What is the format of your disk?

First I tried Exfat. It does not work.

Then Ext4 does not work either.

Now I test NTFS

I tried the exfat format to be working and my configuration is as follows

Yes, I have gone through all the concessions without success. FTP doesn’t work at all when Samba is on. but even if Samba is off, it doesn’t work for whatever reason.

You can’t access it even with samba alone? Do you set user limits for access?

Yes everything has been tested.

Every conceivable configuration and even different USB devices are always the same

So with NTFS it’s now what I find very strange.

Transmission is now not exactly top speed 30mb should also be higher.

Does the hard drive now automatically go into standby or does it run non-stop?

Is it possible to install Mac Os Time machine on it?

Hey, try luci-app-samba for more option and control, in my opinion its helps, but with FTP(vsftp) i have lot of issues to, it can work fine out of box but only for anonymous user, when i try install luci-app-vsftpd for add user access and other option from GUI, any ftp service from main GUI or luci, don’t work at all. I delete all packages vsftp/vsftp-alt and install again one by one, but ftp don’t work. So i need reflash firmware again and again…
For me its very bad experience that out of box some trivial services like samba or ftp don’t work with out problem in Gl.net firmware, (no, its working but with very limited function and can be broken very easy), i have my old router with custom FREE firmware PADAVAN and in there, i don’t have such problem at all, i just click to enable SMB\FTP service, add folder with permission, add user for smb and ftp, all it from web GUI and its work like a rock, don’t have any issues with user access or with old smb v1-v2 devices and reinstall or install packages to add users like a have do in Gl firmware!! :dizzy_face:
And another bad thinks, Gl firmware don’t even have sftp server out of box(all my previous router have it), i don’t understand why its don’t work when i try connect to sftp, i break my head read OWRT manual that you just need goo to System → Administration-ssh enable Lan, but sftp dont work, just randomly i found post from another guy who had same problem and he manually install open-ssh-sftp-server. For me its just crazy that you need waste you time for such trivial thinks like understand that such necessary instrument like sftp even don’t install, its just like you buy a car and don’t have key for open the hood, you and must make your own key to open it. :face_with_spiral_eyes: