Flint 1800 USB3 Wifi 2.4 Problem

Hello I have the Flint and I noticed something for the first time in 30 years in the computer field.

It was tested with different USB3 hard drives and also different cables. From cheap to very expensive, everything was there.

If the disks are connected to the Flint the 2.4GHz Wlan no longer works. Oh all imaginable settings brought no improvement.

Only when the hard drives were disconnected was everything OK again.
I have never had such a problem and is there a solution?

Unfortunately this is not a news…USB3 and wifi signal don’t get along very well.

You could try and mitigate this issue using the longest cable you can get, and locating the disk as far as possible from the Flint. Sometimes aluminum foil can make some good, but not miracles. :man_shrugging:

Wasn’t visible as news. I’ve had this for the first time in 30 years. Absolutely weird … further away brings nothing already tried

Using the usb port at USB2 speeds will immediately solve the interference. I guess you have to choose between fast transfers and wifi, but in applications like SAMBA, DLNA and NAS you will not see much of a regression, moving from USB3 to USB2 devices.
My two cents.

Can you tell me where you switched it to 2.0 or how?


(to remove non-working drivers, use opkg remove. Note: If both UCHI and OHCI drivers fail, we do not have USB 1.1.)

  1. To install USB 2.0 drivers:

opkg install kmod-usb2 insmod ehci-hcd

  1. To install USB 3.0 drivers:

opkg install kmod-usb3 insmod xhci-hcd

The drivers for the usb3 port should provide backward compatibility for a usb2 disk with no modifications to the router.
You should simply try with an older usb2 hdd case, and see if your problems are solved.
Alternatively, if an old case is not available, what you quoted for ehci hcd is fine, but somewhat more drastic to do.
I’m sorry for your inconvenience…I feel it.
I was in your condition too, and learnt the hard way that nothing is better than a router with an esata port.

Can it be that easy???

I just took the printer usb cable for fun, which is not usb 3 and that works, but the transfer of a test file seems to take longer. But I think it can only be a feeling

The slower transfer speed is the drawback you will have by using usb at only 480Mbit/s, but you will not have interferences with 2.4Ghz wifi.
If you want USB3 speeds AND wifi, you can only use 5Ghz frequencies, as they are not bothered by the USB3 operation.

This doesn’t work xhci_hcd still loads and the device still works on USB 3.0
I am interested in knowing how to force USB2.0 on Flint.

So I just did it with the USB 2.0 printer cable and it also works at 2.4 GHz.

At least the WiFi 2.4 no longer crashes.

But I also tested something for fun and fed the USB cable through a metal clothes rail and lo and behold: looks damn stupid but works. So it’s an insulation story from the cable

good idea with the 5GHz but some most cameras and wifi outlets are all running on 2.4

I didn’t have this phenomenon with the Asus router I had before the Flint

This is the situation with usb3 and 2.4ghz frequencies:

  • The radiation from the USB 3 chip on the router board, the usb cable and the USB 3 device you use will affect the WiFi chip running 2.4ghz. THIS IS A FLAT FACT. NOTHING WE CAN DO ABOUT.

  • you can try and insulate those components, using some metal as you did

  • you can use the port with slower devices, with USB 2.0 protocol (don’t need to downgrade the driver as only the radiation from USB 3.0 signal will affect WiFi. USB 2.0 signal is fine)

  • you can only use 5ghz WiFi, as it is not disturbed by USB 3 radiation, but yes, some devices lack 5ghz connectivity, I know.

  • or else, some manufacturers pay attention on where and how they locate the usb components on the board, in order to minimize the interference when usb is working at the same time with 2.4ghz wifi

One last thing you can try is to see if all 13 channels (or how many you have on the Flint) of the 2.4ghz radio are affected by the radiation from usb 3. You might discover that one or two channels can operate better than others.

I’ll get a multi-shielded USB 3 cable tomorrow to test, otherwise I’ll try again with additional insulation.

But it seems to be quite obviously a design flaw of Gl Inet.

Nothing to report about any wifi 2.4G problem. All routers with usb 3.0 has the same problem and it’s as is. The only solution a good shielded cable and 1.5 meters at least. Sorry for my english.

Hello, I have an Asus AX88U here for testing, also with USB3. If I put the hard drive there next to the router and even use the same cables, I don’t have the problem.

You may be right about the rest

No it’s a issue as is. I have many asus routers also, ac and ax models with same problem (with merlin and without this). Including tp-link, tenda…etc. All of them have issues with 2.4Ghz wifi because usb 3.0 and wifi jobs frequencies and resonances are very similar. It’s true that depends alot of in hdd and cable shuields. Sorry for my english.

So I can only tell you that I never had the problem with the AX88U.
But I will still find a solution for this.
I love little Flint.

I still have 3 points that I unfortunately haven’t gotten yet:
A: TimeMachine
B: USB problem
C: possibly 2 different VPN at the same time

That would be great

Your AX88U is running what firmware and the GL-AX1800 is running what?
Straight from the source:

Asus runs on asuswrt merlin and the flint on openwrt. No matter how, the problem does not exist with the same hdd hardware with the asus. Unlike the colleague said that it is all the same with the disturbances