Flint 2 - Docker image img size

I’ve installed the Dockerman on the Flint2 to use containers .
I’ve noticed that it was created a directory with full storage size (opt/docker) of 7,19 gb
now there is no space for containers.

You should not use docker in router. Make another PC such as server. Flint 2 is router.

this is not a reply to my question.

Okay, simple answer: no enough space storage.
Try plug in usb storage and will 100% cpu at all times.
Also, conflict speed wifi/entrnet because overload cpu for docker and USB storages.
You need use another device for docker. For example Pi4 or mini pc nus

But @gianry is right: It‘s not the answer to the question. Even if I agree that running docker on a router is pretty weird and mostly a thing to avoid.

But I am confused about the question anyway. Directories can‘t use up space if they are empty.

@gianry please post the output of df -h

I tried to change the docker root directory without success.
The container building process has done on the internal memory after I’ve changed the directory in the configuration menu .


this is the path for the usb memory


df -h?
Whats about that output?

I’ve checked with “df -h” command and there is space on the usb device but Docker doesnt do the cointainer on the usb device

docker save containers to /var/lib/docker as regular

Try change docker location, many guide say change location in docker config, but easier solution is system link new directory see this

this store all of docker in different place

1 Like

system link temp build directory to new drive folder

How did you check this?

what is the output of ls /opt -h -l

Use @admon command which is more persistent since folder is also a mount.

Not needed anymore, the answer of @4ever_sunshine should be fine.

Excuse me but I’m not very confident with terminal command.
I’ve changed the docker root dir in the configuration menu but as you can see the overview menu displays a different dir.

it depends on the router. i am running containers on MikroTik rb5009 without any issues :wink:

please let me know how to change docker directory ; following info requested …

root@GL-MT6000:~# ls /opt -h -l
drwx–x–x 4 root root 3.4K Feb 27 22:02 containerd
drwx–x— 13 root root 3.4K Feb 27 22:02 docker

I’hope to understand how to change directory. flint 2 cpu power is more or less as Rb5009 .

root@GL-MT6000:~# df -h
Filesystem Size Used Available Use% Mounted on
/dev/root 44.5M 44.5M 0 100% /rom
tmpfs 494.1M 1.8M 492.3M 0% /tmp
/dev/loop0 7.2G 1.0G 6.2G 14% /overlay
overlayfs:/overlay 7.2G 1.0G 6.2G 14% /
tmpfs 512.0K 0 512.0K 0% /dev
/dev/sda1 28.9G 288.0K 28.9G 0% /tmp/mountd/disk1_part1

tried to use mv command but I received error for all the files :
mv: can’t create symlink ‘/tmp/mountd/disk1_part1/docker/docker/vfs/dir/7fba10a178be979e442a958b52dc15ad2ebfc189b73217c98a940dd443d25bed-init/usr/bin/md5sum.textutils’ to ‘md5sum’: Operation not permitted

When I tried to pull the image for docker …

At the end I’ve set an EXTroot on usb drive . now Unifi docker container is working well