Flint 2 (GL-MT6000 ) - bug reports - collective thread

Seem to having issue brining up 5Ghz with 160Mhz bandwidth on 11 ac/ax only.
IPv6 is hit and miss with pass though, but I can get it to work.

2.4Ghz seems much faster on my clients and running 20Mhz 11 n/ax. Previously I have N clients that would not connect using this mode, but had no issues connecting on N with an another Broadcom AX 6000 router and a different Mediatek chipset AX 3000 router.

Can’t do the range test unit I get the 5Ghz up again. I maybe have to drop out of the DFS range and see if that’s the issue. I have it up with channel 128 and 60, but 124 and 120 seem to not want to come up despite………UPDATE:Correction, it just came up. It only took 24 minutes so something is still not correct with that. It shouldn’t take that long to do a DFS scan when I am out in the country and have WiFi scanners running on two other devices so I know those channels are free.

I would say for the most part it seems to be an improvement with 2.4. IPv6 mighty be unrelated to this snapshot firmware. My big concern is the amount of time to 5Ghz on DFS to come up.
I’ll do a range test for distance and compare to what I have documented on previous firmware for the flint2 and the Broadcom chipset AX router I have.

Almost forgot to mention I had two clients (one apple iPad mini 6th gen and one google pixel 7a) that would hardly get any speed on 2.4Ghz if the Bluetooth was turned on at the same time. Both of these clients now seem to work as expected with this snapshot.
So this was fixed with those two clients and 2.4Ghz 11 n/ax client that used to fail to connect are now able to connect under that mode.

Please keep in mind that snapshots (also called nightly builds) are not beta versions. It is best to be patient until there is a new official firmware from a GL employee.

Posting all the bugs from the 4.5.7 snapshot here now makes absolutely no sense.

So it doesn’t make sense to post it so GL employees see what we are seeing and they can possibly correct it before releasing the Beta or official resales that they talked about releasing Monday?
Personally I’m just glad to see 2.4 working better and reaching speeds I have never seen off it before.

1 Like

Seems they have logging set to debug on the snapshots with an increase buffer size to 10240, This is probably the increase of ram usage you are seeing.

1 Like

Yup, makes no sense. This release was not checked by a human. It’s just a bunch of the current code commits.

1 Like

To use the proprietary MediaTek WiFi driver they’ve downgraded from OpenWrt 23.05.0-rc1 all the way to OpenWrt 21.02.0-rc1. But OpenWrt 21.02.x reached it’s end of life in May 2023 :face_with_raised_eyebrow:

4.5.6 stable release:
OpenWrt 23.05-SNAPSHOT, r23001+721-38c150612c

4.5.7 snapshot:
OpenWrt 21.02-SNAPSHOT, r15812+1067-46b6ee7ffc

Technically the builds are newer than 23.05.0-rc1 and 21.02.0-rc1, but the commit ID (e.g. 38c150612c) shows us where GL.iNet started their copy of OpenWrt. And of course they’ve then applied their own fixes and cherry picked some changes from newer OpenWrt snapshots too.

Stability with this approach is questionable though, since they forked OpenWrt 23.05 before it was stable and they haven’t kept their OpenWrt fork in sync with the OpenWrt 23.05 repository, so it’s missing dozens of fixes. For example, with firmware 4.5.6 if you open up /lib/netifd/wireless/mac80211.sh and go to line 148 you’ll notice that it’s missing this change from January 5th. But if you go to line 330 you’ll find this change from January 9th.

Have you tried using official OpenWrt snapshots, just to see how that compares? Because if it works with official OpenWrt snapshots then GL.iNet could fix the problem by rebasing their fork on a newer OpenWrt snapshot.

Rebasing the GL.iNet firmware on a newer OpenWrt snapshot might improve the overall stability, but it won’t do anything to fix the 2.4GHz issue. Although, now that we’ve got a firmware with the proprietary MediaTek WiFi driver to compare against someone could file an issue report to the mt76 repository.

8 Likes

I know it’s hard to do, but the best world will be the open source wifi driver for 5GHz and the closed source one for 2.4GHz

This topic is temporarily closed for at least 4 hours due to a large number of community flags.

This topic was automatically opened after 4 hours.

Hello everyone Here comes our Close source WIFI driver version firmware. We are conduct the test at the same time. you can download and test if you want to try it ahead of time.

5 Likes

How scared should we be about this version? :smile:

2 Likes

The test version is OpenWrt 21.02-SNAPSHOT r15812+1066-46b6ee7ffc.

It’s similar to GL.iNet’s GL-MT6000 snapshot version, but it’s been built from an older branch with a different set of changes applied e.g. an older DDNS version, OpenWrt feeds, different edits to various scripts, 1 or 2 different modules etc.

3 Likes

Thanks Alex.

Can you give an overview of the changes to this alpha build?

If this test proves positive for the wifi stability, does this mean you will regress the version of openwrt to an older version or merge the driver and code uodatws into the latest openwrt (23.05)?

Thanks

Are you able to change the WiFi transmit power in this version?

I haven’t installed it to check, since I don’t currently have the time to test firmwares. But I’d assume you can’t configure them settings without a LuCI app package, like this.

I just hope that this firmware is never released as a beta or stable build, since a downgrade to an old end of life version of OpenWrt isn’t an acceptable solution for new hardware. But as a test build, just to prove that the issues with the mt76 driver, it’s fine.

5 Likes

I’m unable to change the WiFi tranmission power.

According to the WiFiman app its 11dbm on both bands.

Otherwise in a quick test the WiFi seems to run faster, smoother and more responsive. Just the distance is lowered because of the TX power.

Guess this is because of the closed source driver - maybe the connection between OS and driver isn’t completely done yet.

No, it’s not 100 dBm. :laughing:

3 Likes

@alex_zheng @alzhao and other admins, thank you for allowing us to use alpha versions for testing. However, could you include a changelog of the changes you made? Otherwise, we will always question whether there have been changes in 2.4 GHz and other features.

3 Likes

OpenWrt Version: 21.02
Linux kernel: 5.4.238

@bonefire Have you change the TX power in the Web ? or just default ?

Can you SSH the teminal to see the tx power?