Flint 2 (GL-MT6000 ) - bug reports - collective thread

Hi all,


since the GL-MT6000 is pretty new and could still have some bugs I’m opening up this thread so everyone can post his experience here.

Bug Report:

Issue description

My Flint 2 reboots randomly 1 - 2 times per hour. I’m running it as a public WiFi accesspoint in combination with wireguard. I have around 16 clients connect concurrently. A crashlog is created. See below.

Firmware version

4.5.3 and 4.5.2

Steps to reproduce the issue

  1. Run a public WiFi
  2. Use a wireguard VPN
  3. Have plenty of clients
  4. Have the same SSID on both bands

What’s the expected result?

Stable WiFi/router

What’s the actual result?

  • Random reboots


-Use only the 5GHz network, disable 2,4 GHz

Additional details / screenshot / log files

Crashlog #1: crashlog1 - Pastebin.com

Crashlog #2: crashlog2 - Pastebin.com

Crashlog #3: crashlog3 - Pastebin.com

Crashlog #4 (4.5.2): crashlog4 - Pastebin.com


Is there any USB device connected?
In the OpenWrt forums, they are talking about a root cause, which was a faulty power supply.

Yes, a Network VLAN switch which uses 5V. I had the same switch connected to my Flint 1 without any reboots and running stable. The whole setup is connected via a PoE++ splitter, the Flint 1 also had no problems with this.

The power consumption is very similar to the Flint 1 (around 7 Watts).

Do you have a link for the openwrt forum thread?

" Unable to handle kernel access to user memory outside uaccess routines at virtual address 0000000000000008" sounds more like a software problem

Sure: Kernel crash [Help!] - For Developers - OpenWrt Forum

Not exactly the same error, since yours is Comm: hostapd Not tainted 5.15.134 #0 but maybe it’s because your wifi module draws more power and this will be the issue then.

80Mhz did not help, I just measured the voltage under load of the power cable to the Flint 2, stable 11,96 V, the PoE++ splitter can do upto 45W.

The crashes are not happening with a low client amount, e.g. over night.

Does the crash happen if you use the original power?

Could you remove the wireguard profile and generate a config backup?
Please send it to handongming#gl-inet.com

This issue has been confirmed.
It’ll be fixed in next version.

1 Like


Please try this firmware.

Hi Jerry, i saw that the file of that link got deleted. Can you reupload it?

Is anyone having WiFi password problems?
Yesterday I had completely configured it and this morning I couldn’t connect to anything because it was showing that the password was incorrect even though it was saved on all my devices.
I changed from wpa3 to wpa2 and it didn’t work, I had to reset the router.

Changing from WPA3 to 2 requires to forget this network on the device you are entering the credentials.

It seems to be some weird WPA3 stuff.


Thank you, I did that let’s see if it doesn’t happen anymore, I noticed another “bug” I can’t install the sqm on the mt6000 because the openwrt package shows that the Kernel is missing

I’m facing a problem with my Mac air M1 and wifi 5ghz. Not sure if it is the same.
I already forget the network, changed the freq of the wifi, country, wpa3/2, I did everything and nothing works… All the devices is connected to 5ghz but my Mac air only connects to 2.4ghz…

That means your 2,4 and 5Ghz SSID is the same?

Which 5G channel and bandwith (20,40,80,160 Mhz) do you use? Can the Mac actually see the 5G network?

Did you try to create a 5GHz only WIfi network, e.g. as a Guest Network to see if you can connect to this?

so… I had the same problem with my mt3000, but it was because an ethernet cable was connected to one of the ports, after removing it it stopped having this problem, but here on the mt6000 because it has 5 inputs it doesn’t make sense not to use them for account of this problem…

the name of wifi 2.4 and 5 are not the same, 80mhz or 160mhz is the same, I leave the channel as automatic on both

The 2.4ghz and 5ghz SSID are not the same.

2.4ghz is on 20 and 5ghz on 80 (tried with 160 also).

It does not bother me that much because I can still use the 2.4ghz on the Mac.

What model number does your MacBook have?

Switching from ax to ac also doesnt help?

Hmm just a few thoughts :thinking:

  • Do you run the wireless on a different network than lan?

  • from what I have fast scanned in your posts it seems you already tried wpa3 and wpa2, have you considered to use the mixed or the none mixed? please try, sometimes it won’t play nice and even some devices only accept wpa2 tkip which makes it even more insecure, often i found to have success with either wpa2 ccmp or wpa2/wpa3 mixed which remove cipher option in luci though some devices may only work specific for one of the two.

  • have you also tried to uncheck the krack vulnerability checkbox and also 802.1w (managed frame protection) in luci? (In network->wireless->then your wifi edit), sometimes older devices can get stuck on these too.

  • does the log tell something about the repeater function or is it enabled?

^ these are lesser common issues, you also have countries, DFS you may want to look into these aswell.


Also im noticing something to on my end but im still investigating it, i noticed some bridged devices where gre vlan and dsa vlan go down and up really short.

somehow i suspect it may be a dsa issue more, upstream on OpenWrt github i also read some minor issues with auto learning, but the issue i have could also be just a configuration issue on my part for me the wifi does not disconnect but i do see it disconnecting because the bridge reconnects really fast.

Unfortunately i have not the issue id anymore but i did read something about it, on the other hand maybe it is contrack related (my own mistake then😋)

^ this is not a issue anymore after i disabled some ipv6 delegations