Flint 2 (GL-MT6000) unable to create Wireguard profiles

Hi,

I can’t create Wireguard profiles. I get this error:
Unknown error occurred. Please check the network environment or reboot the device.

HTTP response to the POST:
{"id":15,"jsonrpc":"2.0","error":{"message":"Internal error","code":-32603}}

nginx error log:
2023/12/06 12:25:09 [error] 4741#0: *57587 upstream prematurely closed FastCGI stdout while reading response header from upstream, client: 192.168.0.197, server: , request: "POST /rpc HTTP/1.1", subrequest: "/cgi-bin/glc", upstream: "fastcgi://unix:/var/run/fcgiwrap.socket:", host: "192.168.0.1", referrer: "https://192.168.0.1/"

Tested firmware 4.5.3 and 4.5.4.
Rebooted router.
Tried adding profiles with Wireguard server both turned on and off.

Can you describe the steps to reproduce the issue?

@hansome, sure

  1. Configure and start Wireguard Server.
  2. Go to VPN → Wireguard Server → Profiles and press the “+ Add” button. Insert a name and press Apply.

I have an update. I was using 172.30.0.1/24 as Wireguard IPv4 Address. I tried changing to 10.10.0.1/24, then it worked. So it seems that private range 172.16.0.0/12 is not available for wireguard in this device, only 10.0.0.0/8 and 192.168.0.0/16 private ranges seems to work.

Really there should be some documentation or a warning notices if there is a range that is forbidden.

Thank you very much. It’s a bug. We’ll fix it ASAP.