Flint 2 (GL-MT6000 ) VLANs nightmare

Hello everyone,
I have configured 3 VLANs in my Flint 2 (and I want to add more).
The way I implemented it, is more or less what OneMarcFifty describes in his video.

However, I am have huge problems, especially with the main WiFi network (Lan is OK for far).
So, I have created:

3 interfaces IOT, Guest (existing one) and lan (existing one).
I added 3 VLANs using VLAN filtering on the br-lan and I added eth1,eth3,etch4 on the lan (eth2 is used for other things)
image

On the interface, I added the br-lan.1 (which is the PVID I chose for the local traffic) as the interface of the lan interface. However, contrary to the stock setup, I don’t see anything else! The 2 WiFi SSIDs are NOT shown.

image

For reference, this is what is shown on my Flint 1 and what was shown prior to the VLAN setup:

image

So far I haven’t extended the Guest and IoT VLANs to the other Access Point because I have huge problems with the WiFi.

As you can see, the WiFi is associated with the lan interface when I see it’s settings from the Wireless menu. (remember that it’s not visible under the lan in the Interfaces menu)

image

When I try to connect to WiFi, it takes way too much time, like 2-3 minutes. Sometimes, it takes even more like 10 minutes, just to connect! I had zero problems with the WiFi prior to the VLAN configuration, so I need to understand if this something common, if something is wrong etc.
Situation is really bad when I move around the house, to devices are disconnected from the Flint 2.

I would also like to know how other have setup VLANs on Flint 2 since it’s quite different from Flint 1/older openwrt version.

I’m missing something here :slight_smile:

can you show us your bridge vlan filtering settings?

this is in luci → interfaces → devices (tab) → edit br-lan → Bridge Vlan Filtering.

here is how it looks on mine:

169 is for me pvid and managed vlan, only if you configurated it in this window then it can be used in br-lan.

edit:

when you only used br-lan. without the bridge vlan filtering the chances are you are only tagging it upstream, this is basicly the same as unchecking the local checkbox in the screenshot i made, often this gets used for tagging a vlan from a isp thus not creating a 802.1q dsa device, but this does not work purely by appending a id behind it, only if bridge vlan filtering was active.

Of course it’s configured!

1 Like

Kind reminder, the issue is on the main WIFI only. Guest (which is still not attached to the VLAN, is fine)

you need to go to wireless:

and then edit the wireless interface and change device to (edit: i made a mistake), the interface holding br-lan.<vlan id>.

it doesn’t have to be in a bridge, also because a bridge device into other bridge devices might cause issues, fyi that is from here, – though in my case I had no other option due to other tunneling protocols for L2, it still works, but only do so if theres no other option than bridging.

if you use a version based on mediatek sdk you may want to restart the router, why?, because the interfaces only got initialized for wifi on boot, and not via luci.

^ this is some type of incompatibility with luci, i don’t think that get fixed, its very stripped and limited.

if all still not work please click on this icon to paste code:

and post the contents of:

  • /etc/config/network
  • /etc/config/dhcp
  • /etc/config/firewall ← also check on the firewall zone, input has to be set on ACCEPT.
  • /etc/config/wireless

I am confused why it’s needed since as far as I understand, the interface acts as an abstraction layer.
But I will try anddd then I will send the text configuration.

BTW, we have and extremely similar setup with almost identical hardware @xize11 !

Flint 2 ↔ Zyxel GS1900-8 (poe) ↔ Flint 1 (dumb AP)

1 Like